aboutsummaryrefslogtreecommitdiff
path: root/chinese/gugod-clean/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/gugod-clean/Makefile')
-rw-r--r--chinese/gugod-clean/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/chinese/gugod-clean/Makefile b/chinese/gugod-clean/Makefile
index 5d3d585f05bc..d84ea3103665 100644
--- a/chinese/gugod-clean/Makefile
+++ b/chinese/gugod-clean/Makefile
@@ -3,25 +3,24 @@
PORTNAME= gugod-clean
PORTVERSION= 1.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= chinese x11-fonts
MASTER_SITES= ftp://freebsd.sinica.edu.tw/pub/gugod/
MAINTAINER= gugod@gugod.org
COMMENT= Pretty font modifyed from X11 schumacher-clean that match kcfonts
+USES= fonts
RUN_DEPENDS= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf
-RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
- mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
FONTFILES= gugod16.bdf gugod18.bdf gugod20.bdf gugod22.bdf
WRKSRC= ${WRKDIR}
NO_BUILD= yes
-XFONTDIR= ${LOCALBASE}/lib/X11/fonts/local
+FONTNAME= gugod
do-install:
- @${MKDIR} ${STAGEDIR}${XFONTDIR}
- ${INSTALL_DATA} ${FONTFILES:S,^,${WRKSRC}/,} ${STAGEDIR}${XFONTDIR}
+ @${MKDIR} ${STAGEDIR}${FONTSDIR}
+ ${INSTALL_DATA} ${FONTFILES:S,^,${WRKSRC}/,} ${STAGEDIR}${FONTSDIR}
.include <bsd.port.mk>