aboutsummaryrefslogtreecommitdiff
path: root/chinese/ibus-array/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/ibus-array/Makefile')
-rw-r--r--chinese/ibus-array/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/chinese/ibus-array/Makefile b/chinese/ibus-array/Makefile
new file mode 100644
index 000000000000..46e2f59da52f
--- /dev/null
+++ b/chinese/ibus-array/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= ibus-array
+PORTVERSION= 0.1.0
+CATEGORIES= chinese
+
+MAINTAINER= jiashiun@gmail.com
+COMMENT= Array 30 input method for IBus
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= ibus-daemon:textproc/ibus
+RUN_DEPENDS= ibus-daemon:textproc/ibus
+
+GNU_CONFIGURE= yes
+
+USES= autoreconf gettext gmake libtool pkgconfig sqlite
+USE_GNOME+= glib20
+
+USE_GITHUB= yes
+GH_ACCOUNT= lexical
+GH_TAGNAME= release-0.1.0
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
+pre-configure:
+ cd ${WRKSRC} && ./autogen.sh
+
+.include <bsd.port.mk>