aboutsummaryrefslogtreecommitdiff
path: root/chinese/librime/files/patch-boost-1.69
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/librime/files/patch-boost-1.69')
-rw-r--r--chinese/librime/files/patch-boost-1.6913
1 files changed, 13 insertions, 0 deletions
diff --git a/chinese/librime/files/patch-boost-1.69 b/chinese/librime/files/patch-boost-1.69
new file mode 100644
index 000000000000..3873db20f1af
--- /dev/null
+++ b/chinese/librime/files/patch-boost-1.69
@@ -0,0 +1,13 @@
+https://github.com/rime/librime/issues/225
+
+--- CMakeLists.txt.orig 2014-12-21 11:46:44 UTC
++++ CMakeLists.txt
+@@ -38,7 +38,7 @@ set(Boost_USE_MULTITHREADED ON)
+ if(MSVC)
+ set(Boost_USE_STATIC_RUNTIME ON)
+ endif(MSVC)
+-find_package(Boost 1.46.0 REQUIRED COMPONENTS filesystem regex signals system)
++find_package(Boost 1.46.0 REQUIRED COMPONENTS filesystem regex system)
+ if(Boost_FOUND)
+ include_directories(${Boost_INCLUDE_DIRS})
+ link_directories(${Boost_LIBRARY_DIRS})