aboutsummaryrefslogtreecommitdiff
path: root/chinese/miniChinput/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/miniChinput/Makefile')
-rw-r--r--chinese/miniChinput/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/chinese/miniChinput/Makefile b/chinese/miniChinput/Makefile
new file mode 100644
index 000000000000..e1b2f26483b4
--- /dev/null
+++ b/chinese/miniChinput/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: zh-miniChinput
+# Date created: 19 Jul 2003
+# Whom: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= miniChinput
+PORTVERSION= 0.1.9
+CATEGORIES= chinese
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= minichinput
+
+MAINTAINER= statue@freebsd.sinica.edu.tw
+COMMENT= A tiny version of Chinput
+
+HAS_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_XLIB= yes
+ALL_TARGET= all data
+INSTALL_TARGET= install data-install
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,make,${GMAKE},g' ${WRKSRC}/src/Makefile.in
+ @echo "install:" >> ${WRKSRC}/src/IMdkit/Makefile
+ @${REINPLACE_CMD} -e 's#$$(prefix)$$(imdir)/{gb,gbk,big5}#$$(prefix)$$(imdir)/gb $$(prefix)$$(imdir)/gbk $$(prefix)$$(imdir)/big5#g' ${WRKSRC}/ImmModules/turbo/Makefile.in
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>