aboutsummaryrefslogtreecommitdiff
path: root/chinese/p5-Lingua-Han-Utils/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/p5-Lingua-Han-Utils/Makefile')
-rw-r--r--chinese/p5-Lingua-Han-Utils/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/chinese/p5-Lingua-Han-Utils/Makefile b/chinese/p5-Lingua-Han-Utils/Makefile
new file mode 100644
index 000000000000..c3f143201719
--- /dev/null
+++ b/chinese/p5-Lingua-Han-Utils/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Lingua-Han-Utils
+# Date created: 2006-09-06
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Lingua-Han-Utils
+PORTVERSION= 0.05
+CATEGORIES= chinese perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Lingua
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= The utility tools of Chinese character(HanZi)
+
+PERL_CONFIGURE= yes
+
+MAN3= Lingua::Han::Utils.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires Perl 5.6.0 or newer. Install lang/perl5.8 and try again
+.endif
+
+.if ${PERL_LEVEL} < 500800
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Encode/Guess.pm:${PORTSDIR}/converters/p5-Encode
+BUILD_DEPENDS= ${RUN_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>