aboutsummaryrefslogtreecommitdiff
path: root/chinese/phpbb3-tw/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/phpbb3-tw/Makefile')
-rw-r--r--chinese/phpbb3-tw/Makefile22
1 files changed, 6 insertions, 16 deletions
diff --git a/chinese/phpbb3-tw/Makefile b/chinese/phpbb3-tw/Makefile
index 1976964da5fa..83690979afc8 100644
--- a/chinese/phpbb3-tw/Makefile
+++ b/chinese/phpbb3-tw/Makefile
@@ -3,6 +3,7 @@
PORTNAME= phpbb
PORTVERSION= 3.0.11
+PORTREVISION= 1
CATEGORIES= chinese www
MASTER_SITES= http://www.phpbb-tw.net/phpbb/download/ \
http://freebsd.ee.ccu.edu.tw/phpBB/
@@ -35,7 +36,6 @@ SUB_LIST= PHPBBURL="${PHPBBURL}" \
PORTDOCS= *
PLIST_SUB+= PHPBBDIR=${PHPBBDIR} WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
-NO_STAGE= yes
# Set custom variables:
#
PHPBBDIR= ${WWWDOCROOT}/${PHPBBURL}
@@ -58,22 +58,12 @@ pre-everything::
.endif
do-install:
- @ cd ${WRKSRC} && ${COPYTREE_SHARE} . ${PREFIX}/${PHPBBDIR} "! -name config.php"
- @ [ -f ${PREFIX}/${PHPBBDIR}/config.php ] || ${TOUCH} ${PREFIX}/${PHPBBDIR}/config.php
- @ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${PHPBBDIR}
- @ ${CHMOD} -R 0755 ${PREFIX}/${PHPBBDIR}
- @ ${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} \
- ${PHPBBDIR:S|^${PREFIX}/|%D/|}' >> ${TMPPLIST}
- @ ${ECHO_CMD} '@exec ${CHMOD} -R 0755 ${PREFIX}/${PHPBBDIR}' >> ${TMPPLIST}
+ @ cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/${PHPBBDIR} "! -name config.php"
+ @ ${TOUCH} ${STAGEDIR}${PREFIX}/${PHPBBDIR}/config.php.sample
+ @ ${CHMOD} -R 0755 ${STAGEDIR}${PREFIX}/${PHPBBDIR}
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @ ${MKDIR} ${DOCSDIR}
- @ cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${DOCSDIR}
-
-.if !defined(BATCH)
- @ ${CAT} ${PKGMESSAGE}
-.endif
-.endif
+ @ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @ cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>