aboutsummaryrefslogtreecommitdiff
path: root/chinese/pine4/files/patch-ak
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/pine4/files/patch-ak')
-rw-r--r--chinese/pine4/files/patch-ak61
1 files changed, 11 insertions, 50 deletions
diff --git a/chinese/pine4/files/patch-ak b/chinese/pine4/files/patch-ak
index 6ca5d41436cc..dc35ee22e609 100644
--- a/chinese/pine4/files/patch-ak
+++ b/chinese/pine4/files/patch-ak
@@ -1,50 +1,11 @@
-*** imap/Makefile.orig Thu May 30 07:33:10 1996
---- imap/Makefile Sun Jan 12 17:05:17 1997
-***************
-*** 47,53 ****
-
- # ANSI compiler ports. Note for SCO you may have to set LN to "copy -rom"
-
-! a32 a41 aix bsi d-g drs lnx lyn mct mnt neb nxt osf sc5 sco sgi slx sos:
- $(MAKE) build SYSTYPE=ANSI OS=$@
-
- # Non-ANSI compiler ports.
---- 47,53 ----
-
- # ANSI compiler ports. Note for SCO you may have to set LN to "copy -rom"
-
-! a32 a41 aix bsi bsf d-g drs lnx lyn mct mnt neb nxt osf sc5 sco sgi slx sos:
- $(MAKE) build SYSTYPE=ANSI OS=$@
-
- # Non-ANSI compiler ports.
-***************
-*** 82,87 ****
---- 82,90 ----
- bs2:
- $(MAKE) build SYSTYPE=ANSI OS=bsi
-
-+ bsf:
-+ $(MAKE) build OS=bsf PROCESS=an
-+
- pt1:
- $(MAKE) build SYSTYPE=non-ANSI OS=ptx
-
-***************
-*** 92,99 ****
- $(LN) $(SYSTYPE) systype
- cd $(SYSTYPE)/c-client; $(MAKE) $(OS)
- cd $(SYSTYPE)/ms;$(MAKE)
-! cd $(SYSTYPE)/ipopd;$(MAKE)
-! cd $(SYSTYPE)/imapd;$(MAKE)
-
- clean:
- $(RM) systype
---- 95,102 ----
- $(LN) $(SYSTYPE) systype
- cd $(SYSTYPE)/c-client; $(MAKE) $(OS)
- cd $(SYSTYPE)/ms;$(MAKE)
-! # cd $(SYSTYPE)/ipopd;$(MAKE)
-! # cd $(SYSTYPE)/imapd;$(MAKE)
-
- clean:
- $(RM) systype
+--- pico/estruct.h.orig Fri May 29 06:56:52 1998
++++ pico/estruct.h Wed Jul 15 17:02:30 1998
+@@ -125,7 +125,7 @@
+ #define LOBIT_CHAR(C) ((C) > 0x1f && (C) < 0x7f)
+ #define HIBIT_CHAR(C) ((C) > 0x7f && (C) <= 0xff)
+ #define HIBIT_OK(C) (!(gmode & MDHBTIGN))
+-#define VALID_KEY(C) (LOBIT_CHAR(C) || (HIBIT_OK(C) && HIBIT_CHAR(C)))
++#define VALID_KEY(C) (((C) & 0x80) ? 1 : LOBIT_CHAR(C))
+ #define ctrl(c) ((c) & 0x1f) /* control character mapping */
+
+ #define STDIN_FD 0