aboutsummaryrefslogtreecommitdiff
path: root/chinese/qterm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/qterm/Makefile')
-rw-r--r--chinese/qterm/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/chinese/qterm/Makefile b/chinese/qterm/Makefile
index b227fca586f4..836e4cc591e1 100644
--- a/chinese/qterm/Makefile
+++ b/chinese/qterm/Makefile
@@ -10,9 +10,9 @@ MASTER_SITES= SF/qterm/qterm/${PORTVERSION}
MAINTAINER= kaiwang27@gmail.com
COMMENT= BBS client for BSD/Linux
-USES= tar:bzip2 cmake perl5
+USES= qt:4 tar:bzip2 cmake perl5
USE_PERL5= build
-USE_QT4= codecs-cn_run codecs-tw_run gui help-tools_build \
+USE_QT= codecs-cn_run codecs-tw_run gui help-tools_build \
linguist_build moc_build network qt3support_build \
qmake_build rcc_build uic_build xml
USE_XORG= x11 ice
@@ -31,15 +31,18 @@ OPENSSL_USES= ssl
OPENSSL_CMAKE_ON= -DQTERM_ENABLE_SSH:BOOL=TRUE
OPENSSL_CMAKE_OFF= -DQTERM_ENABLE_SSH:BOOL=FALSE
-DBUS_USE= QT4=dbus
+DBUS_USES= qt:4
+DBUS_USE= QT=dbus
DBUS_CMAKE_ON= -DQTERM_ENABLE_DBUS:BOOL=TRUE
DBUS_CMAKE_OFF= -DQTERM_ENABLE_DBUS:BOOL=FALSE
-PHONON_USE= QT4=phonon
+PHONON_USES= qt:4
+PHONON_USE= QT=phonon
PHONON_CMAKE_ON= -DQTERM_ENABLE_PHONON:BOOL=TRUE
PHONON_CMAKE_OFF= -DQTERM_ENABLE_PHONON:BOOL=FALSE
-QTSCRIPT_USE= QT4=script
+QTSCRIPT_USES= qt:4
+QTSCRIPT_USE= QT=script
QTSCRIPT_RUN_DEPENDS= ${QT_PLUGINDIR}/script/libqtscript_core.so:devel/qtscriptgenerator
QTSCRIPT_CMAKE_ON= -DQTERM_ENABLE_SCRIPT:BOOL=TRUE
QTSCRIPT_CMAKE_OFF= -DQTERM_ENABLE_SCRIPT:BOOL=FALSE