aboutsummaryrefslogtreecommitdiff
path: root/chinese/xemacs21/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/xemacs21/Makefile')
-rw-r--r--chinese/xemacs21/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/chinese/xemacs21/Makefile b/chinese/xemacs21/Makefile
new file mode 100644
index 000000000000..52d24d82760c
--- /dev/null
+++ b/chinese/xemacs21/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: zh-xemacs21
+# Date created: 1 October 2000
+# Whom: Jing-Tang Keith Jang <keith@freebsd.sinica.edu.tw>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= chinese editors
+
+COMMENT= ${.CURDIR}/pkg-comment
+PLIST= ${.CURDIR}/pkg-plist
+PKGMESSAGE= ${.CURDIR}/pkg-message
+
+XEMACS_MAJOR_VER= 21
+WITH_XIM= xlib
+BUILD_INPUT_METHOD= xcin2.5:${PORTSDIR}/chinese/xcin25
+
+# xemacs21-mule-common needs this.
+WRKDIR= ${.CURDIR}/../../editors/xemacs21-mule/work
+
+# Fix mule-init.el
+post-patch::
+ @${RM} ${WRKSRC}/lisp/mule/mule-init.elc
+ @(cd ${WRKSRC}; ${PATCH} -q < ${.CURDIR}/files/mule-init.el.diff)
+
+post-install::
+ @${MKDIR} ${PREFIX}/lib/xemacs-${XEMACS_VER}/etc/app-defaults/zh_TW.Big5
+ @${INSTALL_DATA} ${.CURDIR}/../xemacs/files/Emacs ${PREFIX}/lib/xemacs-${XEMACS_VER}/etc/app-defaults/zh_TW.Big5
+ @${INSTALL_DATA} ${.CURDIR}/../xemacs/files/sample.emacs ${PREFIX}/lib/xemacs-${XEMACS_VER}/etc/app-defaults/zh_TW.Big5
+ @${CAT} ${PKGMESSAGE}
+
+.include "${.CURDIR}/../../editors/xemacs21-mule/Makefile"