aboutsummaryrefslogtreecommitdiff
path: root/chinese/xsim/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/xsim/Makefile')
-rw-r--r--chinese/xsim/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/chinese/xsim/Makefile b/chinese/xsim/Makefile
index 0c37b9ae7b46..e229a33c88cb 100644
--- a/chinese/xsim/Makefile
+++ b/chinese/xsim/Makefile
@@ -42,7 +42,7 @@ post-patch:
@${FIND} ${WRKSRC} ! -type d \
-exec ${GREP} -q _CPP_BITS_IOSBASE_H '{}' \; \
-exec ${REINPLACE_CMD} 's/#ifdef _CPP_BITS_IOSBASE_H/#if defined(_IOS_BASE_H) || defined(_CPP_BITS_IOSBASE_H)/g' '{}' \;
- ${REINPLACE_CMD} "s/-O2/${CFLAGS}/g; s,/usr/local,${LOCALBASE},; s|s,@bdblib@,\$$bdblib,|s,@bdblib@,${BDB_LIB_CXX_NAME},|" ${WRKSRC}/configure
+ ${REINPLACE_CMD} "s#-O2#${CFLAGS}#g; s,/usr/local,${LOCALBASE},; s|s,@bdblib@,\$$bdblib,|s,@bdblib@,${BDB_LIB_CXX_NAME},|" ${WRKSRC}/configure
post-install:
${INSTALL_DATA} ${WRKDIR}/xsim.sh ${PREFIX}/bin/xsim