aboutsummaryrefslogtreecommitdiff
path: root/chinese/xsim/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/xsim/Makefile')
-rw-r--r--chinese/xsim/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/chinese/xsim/Makefile b/chinese/xsim/Makefile
index 50ef6c4cd769..65f0065a589d 100644
--- a/chinese/xsim/Makefile
+++ b/chinese/xsim/Makefile
@@ -10,6 +10,8 @@ PORTVERSION= 0.3.9.4
CATEGORIES= chinese
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz \
+ ${PORTNAME}-data-freebsd-gb2312.tar.gz
MAINTAINER= statue@freebsd.sinica.edu.tw
COMMENT= A simple and fast GBK Chinese XIM server
@@ -24,14 +26,13 @@ CONFIGURE_ARGS= --with-cn-locale=EUC
post-patch:
@${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>,' \
${WRKSRC}/xsim/IMdkit/IMConn.c
- @${FIND} ${WRKSRC} -type f -name Makefile.in | ${XARGS} \
- ${REINPLACE_CMD} -e 's,@prefix@/plugins,${DATADIR}/plugins,g' \
- -e 's,@prefix@/dat,${DATADIR}/dat,g' \
- -e 's,@prefix@/bin,${DATADIR}/bin,g'
+ @${FIND} ${WRKSRC} -name xsimrc.in -or -name Makefile.in | ${XARGS} \
+ ${REINPLACE_CMD} -Ee 's,@prefix@/(plugins|dat|bin),${DATADIR}/\1,g'
post-install:
- @${LN} -s ${PREFIX}/share/xsim/bin/xsim ${PREFIX}/bin/xsim
- @cd ${WRKSRC} && make install-data
+ @${LN} -s ${DATADIR}/bin/xsim ${PREFIX}/bin/xsim
+ @${MKDIR} ${DATADIR}/dat
+ @${CP} -R ${WRKDIR}/usr/local/xsim/dat/* ${DATADIR}/dat
@${SED} -e 's,%%X11BASE%%,${X11BASE},g' < ${PKGMESSAGE}
.include <bsd.port.mk>