aboutsummaryrefslogtreecommitdiff
path: root/chinese/ydict/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/ydict/Makefile')
-rw-r--r--chinese/ydict/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/chinese/ydict/Makefile b/chinese/ydict/Makefile
new file mode 100644
index 000000000000..176c7d862e8f
--- /dev/null
+++ b/chinese/ydict/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: ydict
+# Date created: 2011-02-08
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ydict
+PORTVERSION= 1.0.9.2
+CATEGORIES= chinese
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E}
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Command line tool of Yahoo! Dict
+
+LICENSE= GPLv3
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+PLIST_FILES= bin/ydict
+USE_PYTHON_RUN= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/ydict ${PREFIX}/bin/
+
+.include <bsd.port.mk>