aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
Diffstat (limited to 'chinese')
-rw-r--r--chinese/pcmanx/Makefile8
-rw-r--r--chinese/pcmanx/distinfo4
-rw-r--r--chinese/pcmanx/files/patch-src-notifier-notifier-impl.c47
-rw-r--r--chinese/pcmanx/files/patch-src-stringutil.cpp10
-rw-r--r--chinese/pcmanx/files/patch-src-telnetcon.h10
-rw-r--r--chinese/pcmanx/files/patch-src-telnetview.cpp11
-rw-r--r--chinese/pcmanx/files/patch-src-termview.cpp11
-rw-r--r--chinese/pcmanx/pkg-plist3
8 files changed, 55 insertions, 49 deletions
diff --git a/chinese/pcmanx/Makefile b/chinese/pcmanx/Makefile
index e0fd2e8eb2cc..dca641c69bac 100644
--- a/chinese/pcmanx/Makefile
+++ b/chinese/pcmanx/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pcmanx
-PORTVERSION= 0.1.8
+PORTVERSION= 0.2.6
CATEGORIES= chinese net
MASTER_SITES= http://pcmanx.csie.net/release/ \
http://bbs.ilc.edu.tw/~chinsan/pcmanx/
@@ -17,9 +17,10 @@ MAINTAINER= chinsan.tw@gmail.com
COMMENT= PCManX is a BBS client using GTK+ 2.x
USE_GNOME= gtk20 intlhack
-GNU_CONFIGURE= yes
+USE_LIBTOOL_VER=15
USE_X_PREFIX= yes
USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
@@ -32,7 +33,4 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|--tag=CXX||g' ${WRKSRC}/src/Makefile.in
-
.include <bsd.port.mk>
diff --git a/chinese/pcmanx/distinfo b/chinese/pcmanx/distinfo
index b468fb52ad4c..67d6d9a8cf8a 100644
--- a/chinese/pcmanx/distinfo
+++ b/chinese/pcmanx/distinfo
@@ -1,2 +1,2 @@
-MD5 (pcmanx-pure-gtk2-0.1.8.tar.gz) = 8b101c9bc3c8b761e6503dafcf8fab0f
-SIZE (pcmanx-pure-gtk2-0.1.8.tar.gz) = 503749
+MD5 (pcmanx-pure-gtk2-0.2.6.tar.gz) = 0cd39e2c5aba6ff940aa41ecd7c8f681
+SIZE (pcmanx-pure-gtk2-0.2.6.tar.gz) = 544943
diff --git a/chinese/pcmanx/files/patch-src-notifier-notifier-impl.c b/chinese/pcmanx/files/patch-src-notifier-notifier-impl.c
new file mode 100644
index 000000000000..6bde5e05769a
--- /dev/null
+++ b/chinese/pcmanx/files/patch-src-notifier-notifier-impl.c
@@ -0,0 +1,47 @@
+--- src/notifier/notifier-impl.c.orig Mon Jul 25 21:56:10 2005
++++ src/notifier/notifier-impl.c Wed Jul 27 00:40:38 2005
+@@ -160,11 +160,14 @@
+
+ static Win* begin_animation(GtkWidget * win, GtkWidget * context)
+ {
++ int slot, begin;
++ Win *w;
++
+ update_working_area();
+
+- int slot = get_slot(win);
+- int begin = working_area.y + height - slot * NHEIGHT;
+- Win *w = g_new0(Win, 1);
++ slot = get_slot(win);
++ begin = working_area.y + height - slot * NHEIGHT;
++ w = g_new0(Win, 1);
+
+ w->win = win;
+ w->context = context;
+@@ -216,6 +219,8 @@
+ GtkWidget *imageNotify;
+ GtkWidget *labelNotify;
+ GtkWidget *labelCaption;
++ GtkWidget *button;
++ Win *w;
+
+ context = gtk_table_new(2, 2, TRUE);
+
+@@ -245,7 +250,7 @@
+ GTK_FILL, GTK_FILL,
+ 0,0);
+
+- GtkWidget* button = gtk_button_new();
++ button = gtk_button_new();
+ gtk_container_add(GTK_CONTAINER(win), button);
+
+ frame = gtk_frame_new(NULL);
+@@ -261,7 +266,7 @@
+ G_OBJECT(button), "clicked",
+ click_cb, click_cb_data);
+
+- Win* w = begin_animation(win, context);
++ w = begin_animation(win, context);
+ g_free(context_text);
+
+ w->parent = parent;
diff --git a/chinese/pcmanx/files/patch-src-stringutil.cpp b/chinese/pcmanx/files/patch-src-stringutil.cpp
deleted file mode 100644
index dc6f6f01903b..000000000000
--- a/chinese/pcmanx/files/patch-src-stringutil.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/stringutil.cpp.orig Thu Jul 7 14:08:01 2005
-+++ src/stringutil.cpp Wed Jul 20 13:32:46 2005
-@@ -11,6 +11,7 @@
-
- #include "stringutil.h"
- #include <ctype.h>
-+#include <stdio.h>
-
- int strncmpi(const char* str1, const char* str2, size_t len)
- {
diff --git a/chinese/pcmanx/files/patch-src-telnetcon.h b/chinese/pcmanx/files/patch-src-telnetcon.h
deleted file mode 100644
index 6d193f4f2958..000000000000
--- a/chinese/pcmanx/files/patch-src-telnetcon.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/telnetcon.h.orig Tue Jul 19 21:30:01 2005
-+++ src/telnetcon.h Wed Jul 20 13:36:06 2005
-@@ -25,6 +25,7 @@
- #include <string>
- #include <vector>
-
-+#include <sys/types.h>
- #include <netinet/in.h>
-
- using namespace std;
diff --git a/chinese/pcmanx/files/patch-src-telnetview.cpp b/chinese/pcmanx/files/patch-src-telnetview.cpp
deleted file mode 100644
index 229e8450ef12..000000000000
--- a/chinese/pcmanx/files/patch-src-telnetview.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/telnetview.cpp.orig Wed Jul 20 07:07:54 2005
-+++ src/telnetview.cpp Wed Jul 20 13:39:22 2005
-@@ -178,7 +178,7 @@
- "utf-8", m_pTermData->m_Encoding.c_str(), "?", NULL, &wl, NULL);
- if(purl)
- {
-- m_s_ANSIColorStr.clear();
-+ m_s_ANSIColorStr = "";
- GtkClipboard* clipboard = gtk_clipboard_get( GDK_NONE );
- gtk_clipboard_set_text(clipboard, purl, wl );
- clipboard = gtk_clipboard_get( GDK_SELECTION_PRIMARY);
diff --git a/chinese/pcmanx/files/patch-src-termview.cpp b/chinese/pcmanx/files/patch-src-termview.cpp
deleted file mode 100644
index f9cdc6443e2f..000000000000
--- a/chinese/pcmanx/files/patch-src-termview.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/termview.cpp.orig Tue Jul 19 19:37:38 2005
-+++ src/termview.cpp Wed Jul 20 13:27:05 2005
-@@ -728,7 +728,7 @@
- m_s_ANSIColorStr = m_pTermData->GetSelectedTextWithColor(trim);
- else
- {
-- m_s_ANSIColorStr.clear();
-+ m_s_ANSIColorStr = "";
- string text = m_pTermData->GetSelectedText(trim);
-
- gsize wl = 0;
diff --git a/chinese/pcmanx/pkg-plist b/chinese/pcmanx/pkg-plist
index fb8dc14aa50a..627edb535bce 100644
--- a/chinese/pcmanx/pkg-plist
+++ b/chinese/pcmanx/pkg-plist
@@ -1,4 +1,7 @@
bin/pcmanx
+lib/libpcmanx_core.a
+lib/libpcmanx_core.so
+lib/libpcmanx_core.so.0
%%NLS%%share/locale/zh_TW/LC_MESSAGES/pcmanx.mo
%%DATADIR%%/emoticons
%%DATADIR%%/sitelist