aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
Diffstat (limited to 'chinese')
-rw-r--r--chinese/cconv/Makefile10
-rw-r--r--chinese/cconv/files/patch-configure13
2 files changed, 21 insertions, 2 deletions
diff --git a/chinese/cconv/Makefile b/chinese/cconv/Makefile
index 8ffa2aca67f6..1da095d8051d 100644
--- a/chinese/cconv/Makefile
+++ b/chinese/cconv/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cconv
PORTVERSION= 0.6.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= chinese converters
MASTER_SITES= GOOGLE_CODE
@@ -21,4 +21,10 @@ post-patch:
@${REINPLACE_CMD} -e 's|unicode.h||; s|libcconv_la_LDFLAGS|cconv_LDFLAGS|' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|UTF-TW|UTF8-TW|g' ${WRKSRC}/main.c
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ! empty(ICONV_LIB)
+CONFIGURE_ENV+= ICONV_DIR=${ICONV_PREFIX}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/chinese/cconv/files/patch-configure b/chinese/cconv/files/patch-configure
new file mode 100644
index 000000000000..1af92b894160
--- /dev/null
+++ b/chinese/cconv/files/patch-configure
@@ -0,0 +1,13 @@
+--- configure.orig 2010-02-08 03:55:22 UTC
++++ configure
+@@ -19129,10 +19129,6 @@ fi
+ OS_TYPE="-D"`uname -s`
+
+
+-for i in /usr/local/iconv /usr/local /usr; do
+- (test -f $i/lib/libiconv.so ||\
+- test -f $i/lib/libiconv.a) && ICONV_DIR=$i && break
+-done
+
+ if test -z "$ICONV_DIR"; then
+ ICONV_LIBS=""