aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
Diffstat (limited to 'chinese')
-rw-r--r--chinese/Makefile1
-rw-r--r--chinese/sourcehansans-tc-otf/Makefile49
-rw-r--r--chinese/sourcehansans-tc-otf/distinfo3
-rw-r--r--chinese/sourcehansans-tc-otf/files/pkg-message.in7
-rw-r--r--chinese/sourcehansans-tc-otf/pkg-descr14
-rw-r--r--chinese/sourcehansans-tc-otf/pkg-plist16
6 files changed, 90 insertions, 0 deletions
diff --git a/chinese/Makefile b/chinese/Makefile
index 96291be4717a..becfe23ee79e 100644
--- a/chinese/Makefile
+++ b/chinese/Makefile
@@ -103,6 +103,7 @@
SUBDIR += scim-pinyin
SUBDIR += scim-tables
SUBDIR += sourcehansans-sc-otf
+ SUBDIR += sourcehansans-tc-otf
SUBDIR += sourcehanserif-sc-otf
SUBDIR += sourcehanserif-tc-otf
SUBDIR += sunpinyin
diff --git a/chinese/sourcehansans-tc-otf/Makefile b/chinese/sourcehansans-tc-otf/Makefile
new file mode 100644
index 000000000000..7889e4aaa59e
--- /dev/null
+++ b/chinese/sourcehansans-tc-otf/Makefile
@@ -0,0 +1,49 @@
+# $FreeBSD$
+
+PORTNAME= sourcehansans
+PORTVERSION= 2.000
+DISTVERSIONSUFFIX= R
+CATEGORIES= chinese x11-fonts
+PKGNAMESUFFIX= -tc-otf
+# Note: the following PKGNAMEPREFIX is here only for self-documenting purpose;
+# actual prefixing is done by the `chinese' category itself.
+#PKGNAMEPREFIX= zh-
+
+MAINTAINER= hyun@caffeinated.codes
+COMMENT= Traditional Chinese font by Adobe designed for user interfaces
+
+LICENSE= OFL11
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= fonts
+USE_GITHUB= yes
+GH_ACCOUNT= adobe-fonts
+GH_PROJECT= source-han-sans
+
+NO_ARCH= yes
+NO_BUILD= yes
+SUB_FILES= pkg-message
+
+OPTIONS_DEFINE= HW
+OPTIONS_SINGLE= TYPE
+OPTIONS_SINGLE_TYPE= FULL SUBSET
+OPTIONS_DEFAULT= FULL
+OPTIONS_SUB= yes
+
+HW_DESC= Install the half-width font in addition to the full font
+FULL_DESC= Install the full font (can display all CJK)
+SUBSET_DESC= Install the subset font (can display TC only)
+SUBSET_PREVENTS= HW
+SUBSET_PREVENTS_MSG= Half-width can only be installed in addition to the full font
+
+FULL_VARS= FONTNAME=SourceHanSansTC SRCFONTSDIR=OTF/TraditionalChinese
+SUBSET_VARS= FONTNAME=SourceHanSansTW SRCFONTSDIR=SubsetOTF/TW
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${SRCFONTSDIR}/*.otf ${STAGEDIR}${FONTSDIR}
+
+post-install-HW-on:
+ ${INSTALL_DATA} ${WRKSRC}/OTF/TraditionalChineseHW/*.otf ${STAGEDIR}${FONTSDIR}
+
+.include <bsd.port.mk>
diff --git a/chinese/sourcehansans-tc-otf/distinfo b/chinese/sourcehansans-tc-otf/distinfo
new file mode 100644
index 000000000000..f94135bd5cdd
--- /dev/null
+++ b/chinese/sourcehansans-tc-otf/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1543452799
+SHA256 (adobe-fonts-source-han-sans-2.000R_GH0.tar.gz) = 3c4dae5225605a90f115570d1c6a86eea8e6b04057297a5566f72f4e48ed0aa8
+SIZE (adobe-fonts-source-han-sans-2.000R_GH0.tar.gz) = 2093662207
diff --git a/chinese/sourcehansans-tc-otf/files/pkg-message.in b/chinese/sourcehansans-tc-otf/files/pkg-message.in
new file mode 100644
index 000000000000..2e8f2addd159
--- /dev/null
+++ b/chinese/sourcehansans-tc-otf/files/pkg-message.in
@@ -0,0 +1,7 @@
+
+You can start using the font by following this instruction:
+
+Add the following line to the "Files" section of your X.org configuration file:
+
+ FontPath "%%FONTSDIR%%/"
+
diff --git a/chinese/sourcehansans-tc-otf/pkg-descr b/chinese/sourcehansans-tc-otf/pkg-descr
new file mode 100644
index 000000000000..6c6605eb2fb0
--- /dev/null
+++ b/chinese/sourcehansans-tc-otf/pkg-descr
@@ -0,0 +1,14 @@
+Source Han Sans: A new open source Pan-CJK typeface family from Adobe
+
+This is Source Han Sans TC/TW, which supports all four variants in this family
+but prioritizes Traditional Chinese Hanzi over other three.
+
+"Source Han Sans, available in seven weights, is a typeface family which
+provides full support for Japanese, Korean, Traditional Chinese, and Simplified
+Chinese, all in one font. It also includes Latin, Greek, and Cyrillic glyphs
+from our popular Source Sans family. All told, each font weight in the family
+has a total of 65,535 glyphs (the maximum supported in the OpenType format), and
+the entire family rounds out at just under half a million total glyphs."
+--- The Typekit Blog, Adobe
+
+WWW: https://github.com/adobe-fonts/source-han-sans
diff --git a/chinese/sourcehansans-tc-otf/pkg-plist b/chinese/sourcehansans-tc-otf/pkg-plist
new file mode 100644
index 000000000000..387d9baeb8da
--- /dev/null
+++ b/chinese/sourcehansans-tc-otf/pkg-plist
@@ -0,0 +1,16 @@
+%%HW%%%%FONTSDIR%%/SourceHanSansHWTC-Bold.otf
+%%HW%%%%FONTSDIR%%/SourceHanSansHWTC-Regular.otf
+%%FULL%%%%FONTSDIR%%/SourceHanSansTC-Bold.otf
+%%FULL%%%%FONTSDIR%%/SourceHanSansTC-ExtraLight.otf
+%%FULL%%%%FONTSDIR%%/SourceHanSansTC-Heavy.otf
+%%FULL%%%%FONTSDIR%%/SourceHanSansTC-Light.otf
+%%FULL%%%%FONTSDIR%%/SourceHanSansTC-Medium.otf
+%%FULL%%%%FONTSDIR%%/SourceHanSansTC-Normal.otf
+%%FULL%%%%FONTSDIR%%/SourceHanSansTC-Regular.otf
+%%SUBSET%%%%FONTSDIR%%/SourceHanSansTW-Bold.otf
+%%SUBSET%%%%FONTSDIR%%/SourceHanSansTW-ExtraLight.otf
+%%SUBSET%%%%FONTSDIR%%/SourceHanSansTW-Heavy.otf
+%%SUBSET%%%%FONTSDIR%%/SourceHanSansTW-Light.otf
+%%SUBSET%%%%FONTSDIR%%/SourceHanSansTW-Medium.otf
+%%SUBSET%%%%FONTSDIR%%/SourceHanSansTW-Normal.otf
+%%SUBSET%%%%FONTSDIR%%/SourceHanSansTW-Regular.otf