aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
Diffstat (limited to 'chinese')
-rw-r--r--chinese/big5width/Makefile4
-rw-r--r--chinese/dictd-database/Makefile8
-rw-r--r--chinese/iiimf-le-newpy/Makefile4
-rw-r--r--chinese/iiimf-le-ude/Makefile8
-rw-r--r--chinese/scim-pinyin/Makefile14
-rw-r--r--chinese/ve/Makefile8
-rw-r--r--chinese/ve/files/patch-screen.c (renamed from chinese/ve/files/extrapatch-screen.c)0
-rw-r--r--chinese/wenju/Makefile8
-rw-r--r--chinese/wenju/files/configure-getopt.patch11
9 files changed, 7 insertions, 58 deletions
diff --git a/chinese/big5width/Makefile b/chinese/big5width/Makefile
index 7de793bc2c24..b11d2a2c13b1 100644
--- a/chinese/big5width/Makefile
+++ b/chinese/big5width/Makefile
@@ -24,10 +24,6 @@ PLIST_SUB= BASELOCALEDIR=${BASELOCALEDIR} \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 502110
-IGNORE= requires UTF-8 locales in base system
-.endif
-
SRCBASE?= ${PORTSDIR}/../src
SRCDIR= ${SRCBASE}/share/mklocale
diff --git a/chinese/dictd-database/Makefile b/chinese/dictd-database/Makefile
index 1eb31eaed0e7..db185a7fb19d 100644
--- a/chinese/dictd-database/Makefile
+++ b/chinese/dictd-database/Makefile
@@ -38,10 +38,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 502110
-RUN_DEPENDS+= ${LOCALBASE}/share/locale/zh_TW.UTF-8/LC_CTYPE:${PORTSDIR}/misc/utf8locale
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/chinese/iiimf-le-newpy/Makefile b/chinese/iiimf-le-newpy/Makefile
index 7a53267bd850..72086ace3cdc 100644
--- a/chinese/iiimf-le-newpy/Makefile
+++ b/chinese/iiimf-le-newpy/Makefile
@@ -41,10 +41,6 @@ PLIST_SUB+= WANT_XAUX="@comment "
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 503000
-IGNORE= is supported on FreeBSD 5.3 and later only
-.endif
-
CFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CONFIGURE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/chinese/iiimf-le-ude/Makefile b/chinese/iiimf-le-ude/Makefile
index 00048bb6e0ad..a57afede30e0 100644
--- a/chinese/iiimf-le-ude/Makefile
+++ b/chinese/iiimf-le-ude/Makefile
@@ -27,12 +27,6 @@ USE_AUTOTOOLS= automake:19:env autoconf:262:env libtool:15:env
WRKSRC= ${WRKDIR}/${DISTNAME:S/src-//}
BUILDDIR= ${WRKSRC}/leif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 503000
-IGNORE= is supported on FreeBSD 5.3 and later only
-.endif
-
CFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CONFIGURE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
@@ -48,4 +42,4 @@ pre-configure:
@cd ${WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${GMAKE} reconfig
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${GMAKE} config
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/chinese/scim-pinyin/Makefile b/chinese/scim-pinyin/Makefile
index 91c036eba56d..baeac1b046cb 100644
--- a/chinese/scim-pinyin/Makefile
+++ b/chinese/scim-pinyin/Makefile
@@ -24,20 +24,12 @@ USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}"
+ PTHREAD_LIBS="${PTHREAD_LIBS}" \
+ CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
+ LDFLAGS="-L${LOCALBASE}/lib -lintl"
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500035
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/stlport" \
- LDFLAGS="-L${LOCALBASE}/lib -lstlport_gcc -lintl ${PTHREAD_LIBS}"
-.else
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
- LDFLAGS="-L${LOCALBASE}/lib -lintl"
-.endif
-
PLIST_SUB= SKIM="@comment "
pre-fetch:
diff --git a/chinese/ve/Makefile b/chinese/ve/Makefile
index a128535f8992..f935911bb144 100644
--- a/chinese/ve/Makefile
+++ b/chinese/ve/Makefile
@@ -15,10 +15,4 @@ EXTRACT_SUFX= .tgz
MAINTAINER= chinsan@FreeBSD.org
COMMENT= NTHU-CS Maple BBS 2.36 BBS-like editor
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-EXTRA_PATCHES= ${FILESDIR}/extrapatch-screen.c
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/chinese/ve/files/extrapatch-screen.c b/chinese/ve/files/patch-screen.c
index b643c45ad398..b643c45ad398 100644
--- a/chinese/ve/files/extrapatch-screen.c
+++ b/chinese/ve/files/patch-screen.c
diff --git a/chinese/wenju/Makefile b/chinese/wenju/Makefile
index 07a6284935c5..481b7789fcf8 100644
--- a/chinese/wenju/Makefile
+++ b/chinese/wenju/Makefile
@@ -31,10 +31,4 @@ PLIST_SUB+= NLS="@comment "
post-install:
gtk-query-immodules-2.0 > ${PREFIX}/etc/gtk-2.0/gtk.immodules
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500041
-EXTRA_PATCHES+= ${FILESDIR}/configure-getopt.patch
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/chinese/wenju/files/configure-getopt.patch b/chinese/wenju/files/configure-getopt.patch
deleted file mode 100644
index 0c53f78ab71f..000000000000
--- a/chinese/wenju/files/configure-getopt.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Sat Oct 18 04:38:19 2003
-+++ configure Sat Oct 18 04:38:42 2003
-@@ -7889,7 +7889,7 @@
-
-
- GTK2_CFLAGS="`pkg-config --cflags gtk+-2.0`"
--GTK2_LIBS="`pkg-config --libs gtk+-2.0`"
-+GTK2_LIBS="`pkg-config --libs gtk+-2.0` -lgnugetopt"
- GTK2_BINARY_VERSION="`pkg-config --variable=gtk_binary_version gtk+-2.0`"
-
-