aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
Diffstat (limited to 'chinese')
-rw-r--r--chinese/BBMan/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/chinese/BBMan/Makefile b/chinese/BBMan/Makefile
index b32995746bd7..47a57f7ee25e 100644
--- a/chinese/BBMan/Makefile
+++ b/chinese/BBMan/Makefile
@@ -22,10 +22,16 @@ USE_ZIP= yes
WRKSRC= ${WRKDIR}/BBMan
USE_X_PREFIX= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
do-build:
cd ${WRKSRC} && g++ main.cpp `wxgtk2-2.4-config --libs --cxxflags` -I${LOCALBASE}/include -O2 -o BBMan
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/BBMan ${PREFIX}/bin/BBMan
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>