aboutsummaryrefslogtreecommitdiff
path: root/comms/geoid/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/geoid/Makefile')
-rw-r--r--comms/geoid/Makefile40
1 files changed, 0 insertions, 40 deletions
diff --git a/comms/geoid/Makefile b/comms/geoid/Makefile
deleted file mode 100644
index 913d07bf846b..000000000000
--- a/comms/geoid/Makefile
+++ /dev/null
@@ -1,40 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= geoid
-PORTVERSION= 1.0
-DISTVERSIONSUFFIX= .src
-PORTREVISION= 9
-CATEGORIES= comms hamradio
-MASTER_SITES= http://www.w1hkj.com/LinuxApps/
-DISTNAME= fl_geoid
-EXTRACT_SUFX= .src.tar.gz
-
-MAINTAINER= hamradio@FreeBSD.org
-COMMENT= Geodetic computer for amateur radio use
-
-BROKEN= unfetchable
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2020-05-05
-
-LICENSE= GPLv2+ NONE # only one src file contains license
-LICENSE_COMB= multi
-
-LIB_DEPENDS= libfltk.so:x11-toolkits/fltk \
- libfontconfig.so:x11-fonts/fontconfig \
- libpng.so:graphics/png
-
-USES= gmake jpeg xorg
-USE_XORG= x11 xcursor xext xfixes xft xinerama xrender
-MAKEFILE= makefile
-
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/geoid.cxx
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/geoid ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/geoid.png ${STAGEDIR}${PREFIX}/share/pixmaps
- @${MKDIR} ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/country.pos ${STAGEDIR}${DATADIR}
-
-.include <bsd.port.mk>