aboutsummaryrefslogtreecommitdiff
path: root/comms/geoid
diff options
context:
space:
mode:
Diffstat (limited to 'comms/geoid')
-rw-r--r--comms/geoid/Makefile40
-rw-r--r--comms/geoid/distinfo2
-rw-r--r--comms/geoid/files/patch-country.pos14
-rw-r--r--comms/geoid/files/patch-geoid.cxx24
-rw-r--r--comms/geoid/files/patch-makefile19
-rw-r--r--comms/geoid/pkg-descr10
-rw-r--r--comms/geoid/pkg-plist3
7 files changed, 0 insertions, 112 deletions
diff --git a/comms/geoid/Makefile b/comms/geoid/Makefile
deleted file mode 100644
index 913d07bf846b..000000000000
--- a/comms/geoid/Makefile
+++ /dev/null
@@ -1,40 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= geoid
-PORTVERSION= 1.0
-DISTVERSIONSUFFIX= .src
-PORTREVISION= 9
-CATEGORIES= comms hamradio
-MASTER_SITES= http://www.w1hkj.com/LinuxApps/
-DISTNAME= fl_geoid
-EXTRACT_SUFX= .src.tar.gz
-
-MAINTAINER= hamradio@FreeBSD.org
-COMMENT= Geodetic computer for amateur radio use
-
-BROKEN= unfetchable
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2020-05-05
-
-LICENSE= GPLv2+ NONE # only one src file contains license
-LICENSE_COMB= multi
-
-LIB_DEPENDS= libfltk.so:x11-toolkits/fltk \
- libfontconfig.so:x11-fonts/fontconfig \
- libpng.so:graphics/png
-
-USES= gmake jpeg xorg
-USE_XORG= x11 xcursor xext xfixes xft xinerama xrender
-MAKEFILE= makefile
-
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/geoid.cxx
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/geoid ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/geoid.png ${STAGEDIR}${PREFIX}/share/pixmaps
- @${MKDIR} ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/country.pos ${STAGEDIR}${DATADIR}
-
-.include <bsd.port.mk>
diff --git a/comms/geoid/distinfo b/comms/geoid/distinfo
deleted file mode 100644
index 7d87843bac25..000000000000
--- a/comms/geoid/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (fl_geoid.src.tar.gz) = 47af413f0d5fdf0bf1e66c96be7795f41fa5311cc3803b5bec5a5c6e63903430
-SIZE (fl_geoid.src.tar.gz) = 38970
diff --git a/comms/geoid/files/patch-country.pos b/comms/geoid/files/patch-country.pos
deleted file mode 100644
index bbf498e9a908..000000000000
--- a/comms/geoid/files/patch-country.pos
+++ /dev/null
@@ -1,14 +0,0 @@
---- country.pos.orig Sat Dec 16 12:03:41 2006
-+++ country.pos Tue Mar 20 21:06:07 2007
-@@ -30,9 +30,9 @@
- 4U/UN |UN HQ NEW YORK |40 42 N|074 00 W|
- 4V |HAITI |19 00 N|072 24 W|
- 4W |UN HQ NEW YORK |40 42 N|074 00 W|
--4X |ISREAL |32 00 N|035 00 E|
-+4X |ISRAEL |32 00 N|035 00 E|
- 4Y |INT CIVIL AVIATION ORG |40 42 N|074 00 W|
--4Z |ISREAL |32 00 N|035 00 E|
-+4Z |ISRAEL |32 00 N|035 00 E|
- 5A |LIBYA, TRIPOLI |32 30 N|013 00 E|
- 5B |CYPRUS |35 00 N|033 00 E|
- 5C-5G |MOROCO CASABLANCA |33 35 N|007 39 W|
diff --git a/comms/geoid/files/patch-geoid.cxx b/comms/geoid/files/patch-geoid.cxx
deleted file mode 100644
index 354221df959b..000000000000
--- a/comms/geoid/files/patch-geoid.cxx
+++ /dev/null
@@ -1,24 +0,0 @@
---- geoid.cxx.orig Mon Dec 18 13:53:07 2006
-+++ geoid.cxx Tue Mar 20 22:02:44 2007
-@@ -28,10 +28,8 @@
- strFname.append("/.geoid/country.pos");
-
- if (ReadGeoFile((char *)strFname.c_str()) == -1) {
-- strFname = szHomedir;
-- strFname.append("/country.pos");
-- if (ReadGeoFile((char *)strFname.c_str()) == -1) {
-- fl_message("Cannot open %s", (char *)strFname.c_str());
-+ if (ReadGeoFile("%%LOCALBASE%%/share/geoid/country.pos") == -1) {
-+ fl_message("Cannot open country.pos");
- exit(0);
- }
- }
-@@ -46,7 +44,7 @@ int main(int argc, char **argv) {
-
- void About()
- {
-- fl_message("Geodetic computer\nVersion: "VERSION"\nDave Freese\nw1hkj@@w1hkj.com");
-+ fl_message("Geodetic computer\nVersion: " VERSION "\nDave Freese\nw1hkj@@w1hkj.com");
- }
-
- void cbSaveQTH()
diff --git a/comms/geoid/files/patch-makefile b/comms/geoid/files/patch-makefile
deleted file mode 100644
index ad1daec8e83e..000000000000
--- a/comms/geoid/files/patch-makefile
+++ /dev/null
@@ -1,19 +0,0 @@
---- makefile.orig Fri Dec 15 14:36:15 2006
-+++ makefile Tue Mar 20 21:15:16 2007
-@@ -5,7 +5,7 @@
- #----------------------------------------------------------------------------------
- #
-
--CFLAGS = `fltk-config --cxxflags` -Wall -g0 -O2 -fexceptions
-+CFLAGS += `fltk-config --cxxflags` -Wall -g0
-
- LIBS = -lfltk_images -ljpeg -lpng
-
-@@ -13,7 +13,6 @@
-
- OBJECT =
-
--CXX = g++
-
- # ----------------------------------------------------------------------------------
-
diff --git a/comms/geoid/pkg-descr b/comms/geoid/pkg-descr
deleted file mode 100644
index eeb995ac54ab..000000000000
--- a/comms/geoid/pkg-descr
+++ /dev/null
@@ -1,10 +0,0 @@
-Geodetic computer for amateur radio use.
-
-Converts Lat / Lon to Maidenhead Grid Square and reverse
-Computes range in kilometers and great circle bearing between
-QTH and remote site specified by Lat/Lon or Maidenhead Grid Square
-Computes range in kilometers and great circle bearing between QTH and
-a site selected from a database list for all known callsign prefixes
-and their geographic position. Geographic position is by major city.
-
-WWW: http://www.w1hkj.com/#Geoid
diff --git a/comms/geoid/pkg-plist b/comms/geoid/pkg-plist
deleted file mode 100644
index f753f75f9c80..000000000000
--- a/comms/geoid/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/geoid
-share/pixmaps/geoid.png
-%%DATADIR%%/country.pos