aboutsummaryrefslogtreecommitdiff
path: root/comms/gfax/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/gfax/Makefile')
-rw-r--r--comms/gfax/Makefile23
1 files changed, 9 insertions, 14 deletions
diff --git a/comms/gfax/Makefile b/comms/gfax/Makefile
index 326ceae06564..0ecb22ec19ee 100644
--- a/comms/gfax/Makefile
+++ b/comms/gfax/Makefile
@@ -3,34 +3,29 @@
# Whom: John Merryweather Cooper <jmcoopr@webmail.bmi.net>
#
# $FreeBSD$
-# $Id: Makefile,v 1.12 2005/11/10 01:21:02 tmclau02 Exp $
+# $Id: Makefile,v 1.16 2007/01/30 00:19:26 tmclau02 Exp $
#
PORTNAME= gfax
-PORTVERSION= 0.7.3
-PORTREVISION= 4
+PORTVERSION= 0.7.6
CATEGORIES= comms print gnome
MASTER_SITES= http://gfax.cowlug.org/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-1
MAINTAINER= bsd-sharp-list@forge.novell.com
COMMENT= A Mono based pop-up fax manager
-BUILD_DEPENDS= ${X11BASE}/lib/mono/gtk-sharp/gtk-sharp.dll:${PORTSDIR}/x11-toolkits/gtk-sharp10 \
- bash:${PORTSDIR}/shells/bash
-RUN_DEPENDS= ${X11BASE}/lib/mono/gtk-sharp/gtk-sharp.dll:${PORTSDIR}/x11-toolkits/gtk-sharp10 \
- ${LOCALBASE}/bin/sendfax:${PORTSDIR}/comms/hylafax \
- bash:${PORTSDIR}/shells/bash
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
+ ${LOCALBASE}/libdata/pkgconfig/evolution-sharp.pc:${PORTSDIR}/mail/evolution-sharp
+RUN_DEPENDS= ${LOCALBASE}/bin/sendfax:${PORTSDIR}/comms/hylafax \
+ bash:${PORTSDIR}/shells/bash \
+ ${LOCALBASE}/libdata/pkgconfig/evolution-sharp.pc:${PORTSDIR}/mail/evolution-sharp
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-USE_X_PREFIX= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_GNOME= gnomeprefix gnomehier libgnomeprint
+USE_GNOME= gnomeprefix gnomehier libgnomeprint gnomesharp20
STRIP=
-GCONF_SCHEMAS=gfax.schemas
+GCONF_SCHEMAS= gfax.schemas
post-patch:
@${REINPLACE_CMD} -e 's|/bin/bash|${LOCALBASE}/bin/bash|' \