aboutsummaryrefslogtreecommitdiff
path: root/comms/gnokii/files/patch-common-Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/gnokii/files/patch-common-Makefile')
-rw-r--r--comms/gnokii/files/patch-common-Makefile40
1 files changed, 8 insertions, 32 deletions
diff --git a/comms/gnokii/files/patch-common-Makefile b/comms/gnokii/files/patch-common-Makefile
index cb3429e49f99..00c0c733f254 100644
--- a/comms/gnokii/files/patch-common-Makefile
+++ b/comms/gnokii/files/patch-common-Makefile
@@ -1,31 +1,7 @@
---- common/Makefile.orig Sat Nov 8 12:15:34 2003
-+++ common/Makefile Wed Dec 3 21:35:14 2003
-@@ -44,13 +44,10 @@
- snprintf.o
-
- ifndef WIN32_CROSS
--ifdef NO_SHARED
--GNOKII_LIB=libgnokii.a
--else
-+GNOKII_LIBNOSHARED=libgnokii.a
- GNOKII_LIB =libgnokii.so
- GNOKII_LIBM =$(GNOKII_LIB).$(MAJOR_NUMBER)
- GNOKII_LIBMM=$(GNOKII_LIBM).$(MINOR_NUMBER)
--endif
- else
- ifdef NO_SHARED
- GNOKII_LIB=gnokii.lib
-@@ -59,7 +56,7 @@
- endif
- endif
-
--all: $(GNOKII_LIB)
-+all: $(GNOKII_LIB) $(GNOKII_LIBNOSHARED)
-
- phones/PHONES.o:
- $(MAKE) -C phones PHONES.o
-@@ -74,8 +71,7 @@
- $(CC) -o gnokii-debug $(OBJS) phones/PHONES.o links/LINKS.o devices/DEVICES.o ../gnokii/gnokii.o
+--- common/Makefile.orig Thu Jan 8 14:46:16 2004
++++ common/Makefile Thu Jan 8 15:12:15 2004
+@@ -73,8 +73,7 @@
+ $(CC) -o gnokii-debug $(LIBS) $(XPM_LIBS) $(OBJS) phones/PHONES.o links/LINKS.o devices/DEVICES.o ../gnokii/gnokii.o
libgnokii.so: $(OBJS) phones/PHONES.o links/LINKS.o devices/DEVICES.o
- $(CC) -shared -Wl,-soname,$(GNOKII_LIBM) -o $(GNOKII_LIBMM) $(OBJS) phones/PHONES.o links/LINKS.o devices/DEVICES.o
@@ -34,15 +10,15 @@
ln -sf $(GNOKII_LIBM) $(GNOKII_LIB)
libgnokii.a: $(OBJS) phones/PHONES.o links/LINKS.o devices/DEVICES.o
-@@ -102,11 +98,11 @@
-
- install:
+@@ -103,12 +102,11 @@
$(INSTALL) -d $(DESTDIR)$(libdir)
+ $(INSTALL) $(GNOKII_STATIC) $(DESTDIR)$(libdir)
+ ifndef NO_SHARED
- $(INSTALL) $(GNOKII_LIBMM) $(DESTDIR)$(libdir)
- cd $(DESTDIR)$(libdir) && ln -sf $(GNOKII_LIBMM) $(GNOKII_LIBM)
+ $(INSTALL) $(GNOKII_LIBM) $(DESTDIR)$(libdir)
-+ $(INSTALL) $(GNOKII_LIBNOSHARED) $(DESTDIR)$(libdir)
cd $(DESTDIR)$(libdir) && ln -sf $(GNOKII_LIBM) $(GNOKII_LIB)
+ endif
- $(INSTALL) -d $(DESTDIR)$(libdir)/pkgconfig
- $(INSTALL_DATA) gnokii.pc $(DESTDIR)$(libdir)/pkgconfig
+ $(INSTALL) -d $(DESTDIR)$(prefix)/libdata/pkgconfig