aboutsummaryrefslogtreecommitdiff
path: root/comms/ixj
diff options
context:
space:
mode:
Diffstat (limited to 'comms/ixj')
-rw-r--r--comms/ixj/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/comms/ixj/Makefile b/comms/ixj/Makefile
index 3e0cbf7500cd..8b635423ee18 100644
--- a/comms/ixj/Makefile
+++ b/comms/ixj/Makefile
@@ -15,6 +15,12 @@ MAINTAINER= roger@freebsd.org
ONLY_FOR_ARCHS= i386
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
+BROKEN = "Driver has not been updated for 5.x kernels. Still uses machine/ipl.h"
+.endif
+
WRKSRC= ${WRKDIR}/ixj_freebsd
USE_REINPLACE= yes
MAKEFILE= Makefile.BSD
@@ -23,6 +29,7 @@ post-patch:
${CP} ${FILESDIR}/ixj.sh ${WRKSRC}
${REINPLACE_CMD} -e "s@%%PREFIX%%@${PREFIX}@g" ${WRKSRC}/ixj.sh
+
pre-build:
.if !exists(${SRC_BASE}/sys/Makefile)
@${ECHO} "*************************************************"; \
@@ -45,4 +52,4 @@ header-install: patch
@${INSTALL_DATA} ${WRKSRC}/ixjuser.h ${PREFIX}/include/sys
@${INSTALL_DATA} ${WRKSRC}/telephony.h ${PREFIX}/include/sys
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>