aboutsummaryrefslogtreecommitdiff
path: root/comms/kremotecontrol/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/kremotecontrol/Makefile')
-rw-r--r--comms/kremotecontrol/Makefile24
1 files changed, 23 insertions, 1 deletions
diff --git a/comms/kremotecontrol/Makefile b/comms/kremotecontrol/Makefile
index 42d7e7fffe93..d1ab1df6523f 100644
--- a/comms/kremotecontrol/Makefile
+++ b/comms/kremotecontrol/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= kdeutils
-PORTVERSION= 2.2.1
+PORTVERSION= 2.2.2
CATEGORIES?= misc kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -14,11 +14,33 @@ DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
+BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
+ automake14:${PORTSDIR}/devel/automake14 \
+ objprelink:${PORTSDIR}/devel/objprelink
+
USE_KDELIBS_VER=2
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-objprelink
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
+CONFIGURE_ARGS+=--enable-final
+.endif
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.endif
USE_GMAKE= yes
MAN1= efax.1 efix.1 fax.1
+pre-configure:
+ ${MKDIR} ${WRKSRC}/auto-bin
+.for AC in autoconf autoheader
+ ${LN} -sf ${LOCALBASE}/bin/${AC}213 ${WRKSRC}/auto-bin/${AC}
+.endfor
+.for AM in automake aclocal
+ ${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
+.endfor
+ cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ ${GMAKE} -f Makefile.cvs
+
.include <bsd.port.mk>