aboutsummaryrefslogtreecommitdiff
path: root/comms/libirman/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/libirman/Makefile')
-rw-r--r--comms/libirman/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/comms/libirman/Makefile b/comms/libirman/Makefile
index 16bdec829d92..bc523c28f106 100644
--- a/comms/libirman/Makefile
+++ b/comms/libirman/Makefile
@@ -2,22 +2,30 @@
# $FreeBSD$
PORTNAME= libirman
-PORTVERSION= 0.4.6
+PORTVERSION= 0.5.2
CATEGORIES= comms
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
-MAINTAINER= rand@iteris.com
+MAINTAINER= ndowens@yahoo.com
COMMENT= Library for Evation's Irman infrared receiver
LICENSE= LGPL20
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= gmake libtool pkgconfig pathfix
-USES= gmake libtool pathfix
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
-PORTDOCS= README TECHNICAL
+DOCS= AUTHORS ChangeLog README TECHNICAL TODO
+
+OPTIONS_DEFINE= DOCS
+
+do-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR})
OPTIONS_DEFINE= DOCS