aboutsummaryrefslogtreecommitdiff
path: root/comms/lirc
diff options
context:
space:
mode:
Diffstat (limited to 'comms/lirc')
-rw-r--r--comms/lirc/Makefile21
-rw-r--r--comms/lirc/distinfo6
-rw-r--r--comms/lirc/files/lircd.sh.in31
-rw-r--r--comms/lirc/files/patch-configure23
-rw-r--r--comms/lirc/pkg-plist12
5 files changed, 78 insertions, 15 deletions
diff --git a/comms/lirc/Makefile b/comms/lirc/Makefile
index 90f71c1a938b..b12bda07e8bb 100644
--- a/comms/lirc/Makefile
+++ b/comms/lirc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= lirc
-PORTVERSION= 0.7.2
+PORTVERSION= 0.8.0
CATEGORIES= comms
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= lirc
@@ -14,26 +14,36 @@ MASTER_SITE_SUBDIR= lirc
MAINTAINER= doconnor@gsoft.com.au
COMMENT= Linux Infared Remote Control
+USE_BZIP2= yes
USE_XLIB= yes
USE_GETOPT_LONG=yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --disable-manage-devices --with-devdir=/var/lirc
+CONFIGURE_ARGS= --enable-sandboxed --with-devdir=/var/run/lirc
+
+OPTIONS= IRMAN "Build with libirman support" On
+
+USE_RC_SUBR= lircd.sh
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386"
+.if exists(${LOCALBASE}/lib/libvga.so.1)
LIB_DEPENDS+= vga:${PORTSDIR}/graphics/svgalib
PLIST_SUB+= SMODE2=
.else
PLIST_SUB+= SMODE2="@comment "
.endif
+.if defined(WITH_IRMAN)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libirman.a:${PORTSDIR}/comms/libirman
CONFIGURE_ARGS+= --with-driver=irman
+.else
+CONFIGURE_ARGS+= --with-driver=any
+.endif
+
.if ${OSVERSION} >= 500041
# These are already included in the getopt_long case on < 50041
CPPFLAGS+= -I${LOCALBASE}/include
@@ -42,10 +52,11 @@ CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
.endif
MAN1= ircat.1 irexec.1 irpty.1 irrecord.1 irsend.1 irw.1 \
- irxevent.1 mode2.1 smode2.1 xmode2.1
+ irxevent.1 lircrcd.1 mode2.1 smode2.1 xmode2.1
MAN8= lircd.8 lircmd.8
post-install:
+ @${MKDIR} /var/run/lirc
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/comms/lirc/distinfo b/comms/lirc/distinfo
index 6eb34add67f8..2f75ef7768d3 100644
--- a/comms/lirc/distinfo
+++ b/comms/lirc/distinfo
@@ -1,3 +1,3 @@
-MD5 (lirc-0.7.2.tar.gz) = dbf6e75a744b4cf9125adb5390862a70
-SHA256 (lirc-0.7.2.tar.gz) = 794abf260d2d8e627494a702523fad54b65b10245f2f7c5680bf08b430f1ac36
-SIZE (lirc-0.7.2.tar.gz) = 662399
+MD5 (lirc-0.8.0.tar.bz2) = 0bf28bf82c7766a462f90927b6bf3af1
+SHA256 (lirc-0.8.0.tar.bz2) = cc8d7fb41a045278680ea530cffaf05181977f41244b9f0ed64075cd7630b5d2
+SIZE (lirc-0.8.0.tar.bz2) = 514359
diff --git a/comms/lirc/files/lircd.sh.in b/comms/lirc/files/lircd.sh.in
new file mode 100644
index 000000000000..fd282eb70b65
--- /dev/null
+++ b/comms/lirc/files/lircd.sh.in
@@ -0,0 +1,31 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: lircd
+# REQUIRE: DAEMON
+#
+# Add the following line to /etc/rc.conf to enable lircd:
+#
+# lircd_enable="YES"
+#
+
+. %%RC_SUBR%%
+
+name="lircd"
+rcvar=`set_rcvar`
+
+load_rc_config ${name}
+: ${lircd_enable="NO"}
+: ${lircd_device="/dev/lirc0"}
+
+
+prefix=%%PREFIX%%
+procname=${prefix}/sbin/lircd
+pidfile=/var/run/lircd.pid
+lircd_config="${prefix}/etc/lircd.conf"
+required_files=${lircd_config}
+command="${prefix}/sbin/lircd"
+command_args="-d ${lircd_device} ${lircd_config}"
+
+run_rc_command "$1"
diff --git a/comms/lirc/files/patch-configure b/comms/lirc/files/patch-configure
index c10e895f5801..a7eda964bbfb 100644
--- a/comms/lirc/files/patch-configure
+++ b/comms/lirc/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Sun Oct 16 21:23:22 2005
-+++ configure Sun Oct 16 21:23:37 2005
-@@ -7815,6 +7815,7 @@
+--- configure.orig Sat Jan 21 18:03:45 2006
++++ configure Wed Nov 15 12:58:20 2006
+@@ -7816,6 +7816,7 @@
# use fifo instead of devnode (required on mac os x)
@@ -8,3 +8,20 @@
if test "$use_fifos" = "yes"; then
USE_FIFOS_TRUE=
+@@ -9378,6 +9379,8 @@
+ { echo "configure: error: *** you need to have the ALSA libraries and drivers
+ from at least version 1.0.9 for this driver" 1>&2; exit 1; }
+ ;;
++ any)
++ ;;
+ *)
+ { echo "configure: error: *** it is not possible to install the specified driver
+ on this system" 1>&2; exit 1; }
+@@ -9387,6 +9390,7 @@
+
+
+ if test "$lirc_driver" = "none" || \
++ test "$lirc_driver" = "any" || \
+ test "$lirc_driver" = "alsa_usb" || \
+ test "$lirc_driver" = "userspace" || \
+ test "$lirc_driver" = "atilibusb" || \
diff --git a/comms/lirc/pkg-plist b/comms/lirc/pkg-plist
index 365ddb2ba84d..b30e77d6d9f5 100644
--- a/comms/lirc/pkg-plist
+++ b/comms/lirc/pkg-plist
@@ -5,14 +5,18 @@ bin/irrecord
bin/irsend
bin/irw
bin/irxevent
+bin/lircrcd
bin/mode2
%%SMODE2%%bin/smode2
bin/xmode2
-sbin/lircd
-sbin/lircmd
+include/lirc/lirc_client.h
lib/liblirc_client.a
lib/liblirc_client.la
lib/liblirc_client.so
-lib/liblirc_client.so.0
-include/lirc/lirc_client.h
+lib/liblirc_client.so.1
+sbin/lircd
+sbin/lircmd
@dirrm include/lirc
+@exec mkdir -p /var/run/lirc
+@unexec rm -f /var/run/lirc.pid 2> /dev/null || true
+@unexec rm -rf /var/run/lircd 2> /dev/null || true