aboutsummaryrefslogtreecommitdiff
path: root/comms/predict/files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/predict/files/Makefile')
-rw-r--r--comms/predict/files/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/comms/predict/files/Makefile b/comms/predict/files/Makefile
new file mode 100644
index 000000000000..20fb3df53470
--- /dev/null
+++ b/comms/predict/files/Makefile
@@ -0,0 +1,45 @@
+# $FreeBSD$
+
+.ifndef CC
+CC = -cc
+.endif
+.ifndef CPPFLAGS
+CPPFLAGS =
+.endif
+.ifndef CFLAGS
+CFLAGS = -O2
+.endif
+
+default: all
+
+all: predict
+
+SRCS = \
+ predict.c
+
+OBJS = ${SRCS:.c=.o}
+LIBS += -lm -lncurses -o predict
+#
+#
+HDRS = predict.h
+
+predict: ${OBJS} ${HDRS}
+ ${CC} ${CFLAGS} -o $@ ${OBJS} ${LIBS}
+
+.c.o:
+ ${CC} ${CPPFLAGS} ${CFLAGS} -c $<
+
+,v.c:
+ co $<
+
+clean:
+ rm -f *.o predict *core *~ \#* *.txt
+
+install:
+ echo INSTALL
+ install predict ${PREFIX}/bin
+
+install.man:
+ install docs/man/predict.1 ${PREFIX}/man/man1
+
+.PHONY: clean build