aboutsummaryrefslogtreecommitdiff
path: root/comms/ser2net
diff options
context:
space:
mode:
Diffstat (limited to 'comms/ser2net')
-rw-r--r--comms/ser2net/Makefile2
-rw-r--r--comms/ser2net/files/patch-dataxfer.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/comms/ser2net/Makefile b/comms/ser2net/Makefile
index d4b9ae964824..62f8a654b151 100644
--- a/comms/ser2net/Makefile
+++ b/comms/ser2net/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ser2net
PORTVERSION= 2.3
+PORTREVISION= 1
CATEGORIES= comms net
MASTER_SITES= SF
@@ -14,7 +15,6 @@ MAINTAINER= devon.odell@coyotepoint.com
COMMENT= Allows to access serial ports over IP
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --without-uucp-locking
MAN8= ${PORTNAME}.8
PLIST_FILES= sbin/${PORTNAME} etc/${PORTNAME}.conf.sample
USE_RC_SUBR= ${PORTNAME}
diff --git a/comms/ser2net/files/patch-dataxfer.c b/comms/ser2net/files/patch-dataxfer.c
new file mode 100644
index 000000000000..0605114bc62c
--- /dev/null
+++ b/comms/ser2net/files/patch-dataxfer.c
@@ -0,0 +1,11 @@
+--- dataxfer.c.orig Thu Dec 7 20:09:25 2006
++++ dataxfer.c Thu Dec 7 20:10:33 2006
+@@ -53,7 +53,7 @@
+ #endif /* HAVE_TCPD_H */
+
+ #ifdef USE_UUCP_LOCKING
+-static char *uucp_lck_dir = "/var/lock";
++static char *uucp_lck_dir = "/var/spool/lock";
+ #ifndef HAVE_TCPD_H
+ static char *progname = "ser2net";
+ #endif