aboutsummaryrefslogtreecommitdiff
path: root/comms/smstools3/files/patch-src-Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/smstools3/files/patch-src-Makefile')
-rw-r--r--comms/smstools3/files/patch-src-Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/comms/smstools3/files/patch-src-Makefile b/comms/smstools3/files/patch-src-Makefile
index 3f95d2bdf98c..ed41d81adb7e 100644
--- a/comms/smstools3/files/patch-src-Makefile
+++ b/comms/smstools3/files/patch-src-Makefile
@@ -1,5 +1,5 @@
---- src/Makefile.orig 2009-06-01 13:53:29.000000000 +0200
-+++ src/Makefile 2009-06-15 08:59:05.000000000 +0200
+--- src/Makefile.orig 2010-06-16 14:02:36.000000000 +0200
++++ src/Makefile 2010-07-06 22:00:30.303633098 +0200
@@ -1,7 +1,7 @@
# In case of windows, use os_cygwin=yes setting in the configuration file (smsd.conf).
@@ -16,14 +16,14 @@
-CFLAGS += -D NOSTATS
+#CFLAGS += -D NOSTATS
- # Uncomment this to force smsd to run in terminal mode
- #CFLAGS += -D TERMINAL
-@@ -31,7 +31,7 @@
+ # Comment this out if iconv is not available on the system
+ #CFLAGS += -D USE_ICONV
+@@ -50,7 +50,7 @@
ifneq (,$(findstring NOSTATS,$(CFLAGS)))
- $(CC) $(CFLAGS) -o $@ $^
+ $(CC) $(CFLAGS) -o $@ $^ $(LFLAGS)
else
-- $(CC) `mm-config --cflags` $(CFLAGS) -o $@ $^ `mm-config --ldflags --libs`
-+ $(CC) `$(LOCALBASE)/bin/mm-config --cflags` $(CFLAGS) -o $@ $^ `$(LOCALBASE)/bin/mm-config --ldflags --libs`
+- $(CC) `mm-config --cflags` $(CFLAGS) -o $@ $^ `mm-config --ldflags --libs` $(LFLAGS)
++ $(CC) `$(LOCALBASE)/bin/mm-config --cflags` $(CFLAGS) -o $@ $^ `$(LOCALBASE)/bin/mm-config --ldflags --libs` $(LFLAGS)
endif
clean: