aboutsummaryrefslogtreecommitdiff
path: root/comms/soundmodem
diff options
context:
space:
mode:
Diffstat (limited to 'comms/soundmodem')
-rw-r--r--comms/soundmodem/Makefile8
-rw-r--r--comms/soundmodem/files/patch-soundcard_ptt.c4
2 files changed, 4 insertions, 8 deletions
diff --git a/comms/soundmodem/Makefile b/comms/soundmodem/Makefile
index 6787967b6203..516a48e907da 100644
--- a/comms/soundmodem/Makefile
+++ b/comms/soundmodem/Makefile
@@ -7,6 +7,7 @@
PORTNAME= soundmodem
PORTVERSION= 0.10
+PORTREVISION= 1
CATEGORIES= comms hamradio
MASTER_SITES= http://www.baycom.org/~tom/ham/soundmodem/ \
http://chronos.org.uk/distfiles/
@@ -40,9 +41,4 @@ post-patch:
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/soundmodem ${PREFIX}/etc/rc.d
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile on FreeBSD 4.x
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/comms/soundmodem/files/patch-soundcard_ptt.c b/comms/soundmodem/files/patch-soundcard_ptt.c
index e9226630047a..92ba9cf3cb4f 100644
--- a/comms/soundmodem/files/patch-soundcard_ptt.c
+++ b/comms/soundmodem/files/patch-soundcard_ptt.c
@@ -1,5 +1,5 @@
--- soundcard/ptt.c.orig Sat Nov 9 10:31:53 2002
-+++ soundcard/ptt.c Mon Nov 6 00:17:03 2006
++++ soundcard/ptt.c Mon Apr 23 10:24:36 2007
@@ -48,6 +48,9 @@
#ifdef HAVE_LINUX_PPDEV_H
@@ -15,7 +15,7 @@
struct modemparams pttparams[] = {
{ "file", "PTT Driver", "Path name of the serial or parallel port driver for outputting PTT", "none", MODEMPAR_COMBO,
+#ifdef __FreeBSD__
-+ { c: { { "none", "/dev/ttyd0", "/dev/ttyd1", "/dev/lp0", "/dev/lp1" } } } },
++ { c: { { "none", "/dev/ttyd0", "/dev/ttyd1", "/dev/ppi0", "/dev/ppi1" } } } },
+#else
{ c: { { "none", "/dev/ttyS0", "/dev/ttyS1", "/dev/parport0", "/dev/parport1" } } } },
+#endif