aboutsummaryrefslogtreecommitdiff
path: root/comms/tkscanfax/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/tkscanfax/Makefile')
-rw-r--r--comms/tkscanfax/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/comms/tkscanfax/Makefile b/comms/tkscanfax/Makefile
new file mode 100644
index 000000000000..51ba6214f208
--- /dev/null
+++ b/comms/tkscanfax/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: tkscanfax
+# Date created: 11 Mai 2002
+# Whom: MITA Yoshio <mita@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tkscanfax
+PORTVERSION= 1.02
+CATEGORIES= comms
+MASTER_SITES= http://shino.pos.to/linux/
+
+MAINTAINER= mita@FreeBSD.org
+
+RUN_DEPENDS= wish8.0jp:${PORTSDIR}/japanese/tk80
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_BUILD= YES
+
+post-extract:
+ find ${WRKSRC} -name '*~' -delete
+
+do-install:
+ (\
+ cd ${WRKDIR}; \
+ ${TAR} '--exclude=*.orig' -cf - tkscanfax | \
+ ${TAR} -C ${PREFIX}/lib -xf - ; \
+ ${LN} -sf ${PREFIX}/lib/tkscanfax/tkscan ${PREFIX}/bin ; \
+ ${LN} -sf ${PREFIX}/lib/tkscanfax/tkfax ${PREFIX}/bin \
+ )
+
+.include <bsd.port.mk>