aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
Diffstat (limited to 'comms')
-rw-r--r--comms/viewfax/Makefile1
-rw-r--r--comms/viewfax/files/patch-aa2
2 files changed, 2 insertions, 1 deletions
diff --git a/comms/viewfax/Makefile b/comms/viewfax/Makefile
index e84d4067e343..016158a112a4 100644
--- a/comms/viewfax/Makefile
+++ b/comms/viewfax/Makefile
@@ -7,6 +7,7 @@
PORTNAME= viewfax
PORTVERSION= 2.3
+PORTREVISION= 1
CATEGORIES= comms
MASTER_SITES= ftp://ftp.leo.org/pub/comp/os/unix/networking/mgetty/
diff --git a/comms/viewfax/files/patch-aa b/comms/viewfax/files/patch-aa
index 844595ffa52d..b8782ecf2042 100644
--- a/comms/viewfax/files/patch-aa
+++ b/comms/viewfax/files/patch-aa
@@ -5,7 +5,7 @@
n = *r++;
tot += n;
+ /* Watch out for buffer overruns, e.g. when n == 65535. */
-+ if (tot > pn->width)
++ if (tot >= pn->width)
+ break;
if (pix)
acc |= (~(t32bits)0 >> nacc);