aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
Diffstat (limited to 'comms')
-rw-r--r--comms/usrp/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/comms/usrp/Makefile b/comms/usrp/Makefile
index e1262f390522..c82ef1eb09bf 100644
--- a/comms/usrp/Makefile
+++ b/comms/usrp/Makefile
@@ -2,7 +2,7 @@
PORTNAME= usrp
PORTVERSION= 3.4.3
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= comms hamradio
MASTER_SITES= LOCAL/adrian
DISTNAME= Ettus-USRP-3.4.3
@@ -17,12 +17,15 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/tuple/tuple.hpp:devel/boost-libs \
orcc:devel/orc \
sdcc:lang/sdcc
-USES= compiler:c++0x cmake:outsource gmake pkgconfig dos2unix
+USES= compiler:c++0x cmake:outsource gmake pkgconfig python:run \
+ dos2unix shebangfix
COMPILER_FEATURES= libc++
USE_LDCONFIG= yes
CMAKE_SOURCE_PATH= ${WRKSRC}/host
MAKE_JOBS_UNSAFE= yes
+SHEBANG_GLOB= *.py
+
# for excruciating debug use this -db
#CMAKE_ARGS+= --debug-output --trace
DOCSDIR= share/doc/uhd