aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
Diffstat (limited to 'comms')
-rw-r--r--comms/xnec2c/Makefile10
-rw-r--r--comms/xnec2c/files/cexp.c46
-rw-r--r--comms/xnec2c/files/cexp.h9
3 files changed, 2 insertions, 63 deletions
diff --git a/comms/xnec2c/Makefile b/comms/xnec2c/Makefile
index 4dd2cec34ffc..3aeba4e225f9 100644
--- a/comms/xnec2c/Makefile
+++ b/comms/xnec2c/Makefile
@@ -21,18 +21,12 @@ USE_GNOME= gtk20 intltool
OPTIONS_DEFINE= DOCS
OPTIONS_SUB= yes
-.include <bsd.port.pre.mk>
-
post-extract:
${CP} ${PATCHDIR}/clog.c ${WRKSRC}/src
-.if ${OSVERSION} < 900000
- ${CP} ${PATCHDIR}/cexp.[ch] ${WRKSRC}/src
-.else
${TOUCH} ${WRKSRC}/src/cexp.c
${TOUCH} ${WRKSRC}/src/cexp.h
-.endif
-post-install:
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/xnec2c.html ${STAGEDIR}${DOCSDIR}/xnec2c.html
${MKDIR} ${STAGEDIR}${DOCSDIR}/images
@@ -44,4 +38,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/images/radiation.png ${STAGEDIR}${DOCSDIR}/images/radiation.png
${INSTALL_DATA} ${WRKSRC}/doc/images/wire.png ${STAGEDIR}${DOCSDIR}/images/wire.png
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/comms/xnec2c/files/cexp.c b/comms/xnec2c/files/cexp.c
deleted file mode 100644
index 595e913be5d8..000000000000
--- a/comms/xnec2c/files/cexp.c
+++ /dev/null
@@ -1,46 +0,0 @@
-/* $NetBSD: cexp.c,v 1.1 2007/08/20 16:01:34 drochner Exp $ */
-
-/*-
- * Copyright (c) 2007 The NetBSD Foundation, Inc.
- * All rights reserved.
- *
- * This code is derived from software written by Stephen L. Moshier.
- * It is redistributed by the NetBSD Foundation by permission of the author.
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted provided that the following conditions
- * are met:
- * 1. Redistributions of source code must retain the above copyright
- * notice, this list of conditions and the following disclaimer.
- * 2. Redistributions in binary form must reproduce the above copyright
- * notice, this list of conditions and the following disclaimer in the
- * documentation and/or other materials provided with the distribution.
- *
- * THIS SOFTWARE IS PROVIDED BY THE NETBSD FOUNDATION, INC. AND CONTRIBUTORS
- * ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
- * TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
- * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE FOUNDATION OR CONTRIBUTORS
- * BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
- * CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
- * SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
- * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
- * CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
- * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
- * POSSIBILITY OF SUCH DAMAGE.
- */
-
-#include <complex.h>
-#include <math.h>
-
-double complex
-cexp(double complex z)
-{
- double complex w;
- double r, x, y;
-
- x = creal(z);
- y = cimag(z);
- r = exp(x);
- w = r * cos(y) + r * sin(y) * I;
- return w;
-}
diff --git a/comms/xnec2c/files/cexp.h b/comms/xnec2c/files/cexp.h
deleted file mode 100644
index 41d925046428..000000000000
--- a/comms/xnec2c/files/cexp.h
+++ /dev/null
@@ -1,9 +0,0 @@
-#ifndef CEXP_H_
-#define CEXP_H_
-
-#include <complex.h>
-#include <math.h>
-
-double complex cexp(double complex z);
-
-#endif