aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
Diffstat (limited to 'comms')
-rw-r--r--comms/gstreamer1-plugins-spandsp/Makefile2
-rw-r--r--comms/spandsp-devel/Makefile3
-rw-r--r--comms/spandsp/Makefile10
-rw-r--r--comms/spandsp/distinfo4
-rw-r--r--comms/spandsp/files/patch-Makefile.am11
-rw-r--r--comms/spandsp/files/patch-configure.ac33
-rw-r--r--comms/spandsp/pkg-plist82
7 files changed, 131 insertions, 14 deletions
diff --git a/comms/gstreamer1-plugins-spandsp/Makefile b/comms/gstreamer1-plugins-spandsp/Makefile
index 8ab43117c1a0..1506a243d261 100644
--- a/comms/gstreamer1-plugins-spandsp/Makefile
+++ b/comms/gstreamer1-plugins-spandsp/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= comms
COMMENT= Gstreamer DSP library and software FAX machine plugin
diff --git a/comms/spandsp-devel/Makefile b/comms/spandsp-devel/Makefile
index 2179bf3dbbb5..7c5e8680ea05 100644
--- a/comms/spandsp-devel/Makefile
+++ b/comms/spandsp-devel/Makefile
@@ -11,6 +11,9 @@ PKGNAMESUFFIX= -devel
MAINTAINER= ports@FreeBSD.org
COMMENT= DSP library and software FAX machine
+DEPRECATED= Use newer comms/spandsp
+EXPIRATION_DATE=2015-01-15
+
LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff
WRKSRC= ${WRKDIR}/spandsp-${DISTVERSION:C/pre.*//}
diff --git a/comms/spandsp/Makefile b/comms/spandsp/Makefile
index e8a0d00317c2..1650c3cab6d0 100644
--- a/comms/spandsp/Makefile
+++ b/comms/spandsp/Makefile
@@ -2,20 +2,20 @@
# $FreeBSD$
PORTNAME= spandsp
-PORTVERSION= 0.0.5
-PORTREVISION= 1
+PORTVERSION= 0.0.6
CATEGORIES= comms
-MASTER_SITES= http://www.soft-switch.org/downloads/spandsp/ \
- http://www.soft-switch.org/downloads/spandsp/old/
+MASTER_SITES= http://www.soft-switch.org/downloads/spandsp/
MAINTAINER= ports@FreeBSD.org
COMMENT= DSP library and software FAX machine
+LICENSE= LGPL21
+
LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= autoreconf gmake libtool tar:tgz
+USES= autoreconf gmake libtool
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
diff --git a/comms/spandsp/distinfo b/comms/spandsp/distinfo
index 83ba5f9ce830..b486ff476e6a 100644
--- a/comms/spandsp/distinfo
+++ b/comms/spandsp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (spandsp-0.0.5.tgz) = 07f42a237c77b08fa765c3a148c83cdfa267bf24c0ab681d80b90d30dd0b3dbf
-SIZE (spandsp-0.0.5.tgz) = 2506742
+SHA256 (spandsp-0.0.6.tar.gz) = cc053ac67e8ac4bb992f258fd94f275a7872df959f6a87763965feabfdcc9465
+SIZE (spandsp-0.0.6.tar.gz) = 3309837
diff --git a/comms/spandsp/files/patch-Makefile.am b/comms/spandsp/files/patch-Makefile.am
new file mode 100644
index 000000000000..ce87f18afc76
--- /dev/null
+++ b/comms/spandsp/files/patch-Makefile.am
@@ -0,0 +1,11 @@
+--- Makefile.am.orig 2014-09-03 14:15:04.000000000 +0300
++++ Makefile.am 2014-09-03 14:15:16.000000000 +0300
+@@ -61,7 +61,7 @@ SUBDIRS = src $(MAYBE_DOC) $(MAYBE_TESTD
+
+ DIST_SUBDIRS = src doc test-data spandsp-sim tests
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(libdir)data/pkgconfig
+ pkgconfig_DATA = spandsp.pc
+
+ faq: faq.xml
diff --git a/comms/spandsp/files/patch-configure.ac b/comms/spandsp/files/patch-configure.ac
index 25ff48714358..6863077083ad 100644
--- a/comms/spandsp/files/patch-configure.ac
+++ b/comms/spandsp/files/patch-configure.ac
@@ -1,6 +1,6 @@
---- configure.ac.orig 2012-09-01 12:05:10.795461874 +0100
-+++ configure.ac 2012-09-01 12:05:47.473457036 +0100
-@@ -194,7 +194,6 @@
+--- configure.ac.orig 2014-11-11 15:56:10.000000000 +0100
++++ configure.ac 2014-11-11 15:58:13.000000000 +0100
+@@ -198,7 +198,6 @@ AC_CHECK_HEADERS([stdlib.h])
AC_CHECK_HEADERS([string.h])
AC_CHECK_HEADERS([strings.h])
AC_CHECK_HEADERS([malloc.h])
@@ -8,3 +8,30 @@
AC_CHECK_HEADERS([math.h], [INSERT_MATH_HEADER="#include <math.h>"])
AC_CHECK_HEADERS([float.h])
AC_CHECK_HEADERS([fcntl.h])
+@@ -331,7 +330,7 @@ AX_CHECK_EXPORT_CAPABILITY([$host],
+
+ case "${ax_cv_c_compiler_vendor}" in
+ gnu)
+- COMP_VENDOR_CFLAGS="-std=gnu99 -ffast-math -Wall -Wunused-variable -Wunused-but-set-variable -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes $COMP_VENDOR_CFLAGS"
++ COMP_VENDOR_CFLAGS="-std=gnu99 -ffast-math -Wall -Wunused-variable -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes $COMP_VENDOR_CFLAGS"
+ if test "$enable_avx" = "yes" ; then
+ COMP_VENDOR_CFLAGS="-mavx $COMP_VENDOR_CFLAGS"
+ fi
+@@ -392,7 +391,7 @@ sun)
+ REMOVE_FROM_VAR(CFLAGS, -Xc)
+ ;;
+ intel)
+- COMP_VENDOR_CFLAGS="-std=c99 -D_POSIX_C_SOURCE=2 -D_GNU_SOURCE=1 -Wall -Wunused-variable -Wunused-but-set-variable -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes $COMP_VENDOR_CFLAGS"
++ COMP_VENDOR_CFLAGS="-std=c99 -D_POSIX_C_SOURCE=2 -D_GNU_SOURCE=1 -Wall -Wunused-variable -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes $COMP_VENDOR_CFLAGS"
+ if test "$enable_avx" = "yes" ; then
+ COMP_VENDOR_CFLAGS="-mavx $COMP_VENDOR_CFLAGS"
+ fi
+@@ -426,7 +425,7 @@ intel)
+ COMP_VENDOR_LDFLAGS=
+ ;;
+ *)
+- COMP_VENDOR_CFLAGS="-std=c99 -Wall -Wunused-variable -Wunused-but-set-variable -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes $COMP_VENDOR_CFLAGS"
++ COMP_VENDOR_CFLAGS="-std=c99 -Wall -Wunused-variable -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes $COMP_VENDOR_CFLAGS"
+ COMP_VENDOR_LDFLAGS=
+ ;;
+ esac
diff --git a/comms/spandsp/pkg-plist b/comms/spandsp/pkg-plist
index c0bb10cf514b..26cc7a306f4e 100644
--- a/comms/spandsp/pkg-plist
+++ b/comms/spandsp/pkg-plist
@@ -51,7 +51,6 @@ include/spandsp/t35.h
include/spandsp/t38_core.h
include/spandsp/t38_gateway.h
include/spandsp/t38_terminal.h
-include/spandsp/t4.h
include/spandsp/telephony.h
include/spandsp/time_scale.h
include/spandsp/timing.h
@@ -70,7 +69,84 @@ include/spandsp/v8.h
include/spandsp/vector_float.h
include/spandsp/vector_int.h
include/spandsp/version.h
+include/spandsp/ademco_contactid.h
+include/spandsp/complex_vector_int.h
+include/spandsp/expose.h
+include/spandsp/fast_convert.h
+include/spandsp/fax_modems.h
+include/spandsp/image_translate.h
+include/spandsp/math_fixed.h
+include/spandsp/private/ademco_contactid.h
+include/spandsp/private/adsi.h
+include/spandsp/private/async.h
+include/spandsp/private/at_interpreter.h
+include/spandsp/private/awgn.h
+include/spandsp/private/bell_r2_mf.h
+include/spandsp/private/bert.h
+include/spandsp/private/bitstream.h
+include/spandsp/private/dtmf.h
+include/spandsp/private/echo.h
+include/spandsp/private/fax.h
+include/spandsp/private/fax_modems.h
+include/spandsp/private/fsk.h
+include/spandsp/private/g711.h
+include/spandsp/private/g722.h
+include/spandsp/private/g726.h
+include/spandsp/private/gsm0610.h
+include/spandsp/private/hdlc.h
+include/spandsp/private/ima_adpcm.h
+include/spandsp/private/image_translate.h
+include/spandsp/private/logging.h
+include/spandsp/private/lpc10.h
+include/spandsp/private/modem_connect_tones.h
+include/spandsp/private/modem_echo.h
+include/spandsp/private/noise.h
+include/spandsp/private/oki_adpcm.h
+include/spandsp/private/queue.h
+include/spandsp/private/schedule.h
+include/spandsp/private/sig_tone.h
+include/spandsp/private/silence_gen.h
+include/spandsp/private/super_tone_rx.h
+include/spandsp/private/super_tone_tx.h
+include/spandsp/private/swept_tone.h
+include/spandsp/private/t30.h
+include/spandsp/private/t30_dis_dtc_dcs_bits.h
+include/spandsp/private/t31.h
+include/spandsp/private/t38_core.h
+include/spandsp/private/t38_gateway.h
+include/spandsp/private/t38_non_ecm_buffer.h
+include/spandsp/private/t38_terminal.h
+include/spandsp/private/t4_rx.h
+include/spandsp/private/t4_t6_decode.h
+include/spandsp/private/t4_t6_encode.h
+include/spandsp/private/t4_tx.h
+include/spandsp/private/time_scale.h
+include/spandsp/private/timezone.h
+include/spandsp/private/tone_detect.h
+include/spandsp/private/tone_generate.h
+include/spandsp/private/v17rx.h
+include/spandsp/private/v17tx.h
+include/spandsp/private/v18.h
+include/spandsp/private/v22bis.h
+include/spandsp/private/v27ter_rx.h
+include/spandsp/private/v27ter_tx.h
+include/spandsp/private/v29rx.h
+include/spandsp/private/v29tx.h
+include/spandsp/private/v42.h
+include/spandsp/private/v42bis.h
+include/spandsp/private/v8.h
+include/spandsp/saturated.h
+include/spandsp/stdbool.h
+include/spandsp/swept_tone.h
+include/spandsp/t38_non_ecm_buffer.h
+include/spandsp/t4_rx.h
+include/spandsp/t4_t6_decode.h
+include/spandsp/t4_t6_encode.h
+include/spandsp/t4_tx.h
+include/spandsp/timezone.h
+include/spandsp/v18.h
lib/libspandsp.a
lib/libspandsp.so
-lib/libspandsp.so.1
-lib/libspandsp.so.1.0.0
+lib/libspandsp.so.2
+lib/libspandsp.so.2.0.0
+libdata/pkgconfig/spandsp.pc