aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/ath3k-firmware/Makefile40
-rw-r--r--comms/ath3k-firmware/distinfo3
-rw-r--r--comms/ath3k-firmware/files/ath3k.conf.in80
-rw-r--r--comms/ath3k-firmware/pkg-descr4
-rw-r--r--comms/ath3k-firmware/pkg-plist20
6 files changed, 148 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index e579b23cece0..88c7faf8f2d0 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -10,6 +10,7 @@
SUBDIR += anyremote
SUBDIR += apitran
SUBDIR += aprsd
+ SUBDIR += ath3k-firmware
SUBDIR += atslog
SUBDIR += bfhist
SUBDIR += bforce-kst
diff --git a/comms/ath3k-firmware/Makefile b/comms/ath3k-firmware/Makefile
new file mode 100644
index 000000000000..b2a47b5ef217
--- /dev/null
+++ b/comms/ath3k-firmware/Makefile
@@ -0,0 +1,40 @@
+# Created by: Vladimir Kondratyev <wulf@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= ath3k-firmware
+PORTVERSION= 20161130
+CATEGORIES= comms
+MASTER_SITES= DEBIAN/pool/non-free/f/firmware-nonfree/
+DISTNAME= firmware-atheros_${PORTVERSION}-4_all
+EXTRACT_SUFX= .deb
+
+MAINTAINER= wulf@FreeBSD.org
+COMMENT= Atheros AR3011/AR3012 bluetooth adaptor firmwares used by ath3kfw(8)
+
+LICENSE= ATHEROS
+LICENSE_NAME= Atheros firmware license
+LICENSE_FILE= ${WRKDIR}/usr/share/doc/firmware-atheros/copyright
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+EXTRACT_CMD= ${AR}
+EXTRACT_BEFORE_ARGS= -p
+EXTRACT_AFTER_ARGS= data.tar.xz | ${TAR} -xf - ${EXTRACT_FILES}
+EXTRACT_FILES= lib/firmware/ar3k \
+ lib/firmware/ath3k-1.fw \
+ usr/share/doc/firmware-atheros/copyright
+
+# Do not track for firmware updates that are irrelevant for us
+# ath3k-firmware is a rather stable part of larger distribution package
+PORTSCOUT= ignore:1
+
+SUB_FILES= ath3k.conf
+
+do-install:
+ cd ${WRKDIR}/lib/firmware && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} \
+ ${WRKDIR}/ath3k.conf ${STAGEDIR}${PREFIX}/etc/devd/ath3k.conf
+
+.include <bsd.port.mk>
diff --git a/comms/ath3k-firmware/distinfo b/comms/ath3k-firmware/distinfo
new file mode 100644
index 000000000000..7c8b35a2ec45
--- /dev/null
+++ b/comms/ath3k-firmware/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1544093347
+SHA256 (firmware-atheros_20161130-4_all.deb) = 1f40b7d4008b0602a2de54aa096995aa3aeeb3426e136a1e0130de7b17bdf523
+SIZE (firmware-atheros_20161130-4_all.deb) = 3131644
diff --git a/comms/ath3k-firmware/files/ath3k.conf.in b/comms/ath3k-firmware/files/ath3k.conf.in
new file mode 100644
index 000000000000..87d5558ac9cc
--- /dev/null
+++ b/comms/ath3k-firmware/files/ath3k.conf.in
@@ -0,0 +1,80 @@
+# pre-commit hook requires that:
+# $FreeBSD$
+
+# Atheros AR3011 with sflash firmware
+notify 100 {
+ match "system" "USB";
+ match "subsystem" "DEVICE";
+ match "type" "ATTACH";
+ match "vendor" "0x0cf3";
+ match "product" "0x3000";
+ action "/usr/sbin/ath3kfw -d $cdev -f %%DATADIR%%";
+};
+
+# Atheros AR3012 with sflash firmware
+notify 100 {
+ match "system" "USB";
+ match "subsystem" "DEVICE";
+ match "type" "ATTACH";
+ match "vendor" "0x0489";
+ match "product" "(0xe04d|0xe04e|0xe056|0xe057|0xe05f|0xe076|0xe078|0xe095)";
+ action "/usr/sbin/ath3kfw -d $cdev -f %%DATADIR%%";
+};
+notify 100 {
+ match "system" "USB";
+ match "subsystem" "DEVICE";
+ match "type" "ATTACH";
+ match "vendor" "0x04c5";
+ match "product" "0x1330";
+ action "/usr/sbin/ath3kfw -d $cdev -f %%DATADIR%%";
+};
+notify 100 {
+ match "system" "USB";
+ match "subsystem" "DEVICE";
+ match "type" "ATTACH";
+ match "vendor" "0x04ca";
+ match "product" "(0x3004|0x3005|0x3006|0x3007|0x3008|0x300b|0x300d|0x300f|0x3010|0x3014|0x3018)";
+ action "/usr/sbin/ath3kfw -d $cdev -f %%DATADIR%%";
+};
+notify 100 {
+ match "system" "USB";
+ match "subsystem" "DEVICE";
+ match "type" "ATTACH";
+ match "vendor" "0x0930";
+ match "product" "(0x0219|0x021c|0x0220|0x0227)";
+ action "/usr/sbin/ath3kfw -d $cdev -f %%DATADIR%%";
+};
+notify 100 {
+ match "system" "USB";
+ match "subsystem" "DEVICE";
+ match "type" "ATTACH";
+ match "vendor" "0x0b05";
+ match "product" "0x17d0";
+ action "/usr/sbin/ath3kfw -d $cdev -f %%DATADIR%%";
+};
+notify 100 {
+ match "system" "USB";
+ match "subsystem" "DEVICE";
+ match "type" "ATTACH";
+ match "vendor" "0x0cf3";
+ match "product" "(0x0036|0x3004|0x3005|0x3008|0x311d|0x311e|0x311f|0x3121|0x817a|0x817b|0xe003|0xe004|0xe005|0xe006)";
+ action "/usr/sbin/ath3kfw -d $cdev -f %%DATADIR%%";
+};
+notify 100 {
+ match "system" "USB";
+ match "subsystem" "DEVICE";
+ match "type" "ATTACH";
+ match "vendor" "0x13d3";
+ match "product" "(0x3362|0x3375|0x3393|0x3402|0x3408|0x3423|0x3432|0x3472|0x3474|0x3487|0x3490)";
+ action "/usr/sbin/ath3kfw -d $cdev -f %%DATADIR%%";
+};
+
+# Atheros AR5BBU22 with sflash firmware */
+notify 100 {
+ match "system" "USB";
+ match "subsystem" "DEVICE";
+ match "type" "ATTACH";
+ match "vendor" "0x0489";
+ match "product" "(0xe036|0xe03c)";
+ action "/usr/sbin/ath3kfw -d $cdev -f %%DATADIR%%";
+};
diff --git a/comms/ath3k-firmware/pkg-descr b/comms/ath3k-firmware/pkg-descr
new file mode 100644
index 000000000000..928be5cd1c92
--- /dev/null
+++ b/comms/ath3k-firmware/pkg-descr
@@ -0,0 +1,4 @@
+Firmware for the Atheros AR3011/AR3012 chip based Bluetooth USB devices.
+To be downloaded with ath3kfw(8).
+
+WWW: https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
diff --git a/comms/ath3k-firmware/pkg-plist b/comms/ath3k-firmware/pkg-plist
new file mode 100644
index 000000000000..c690d9e760ea
--- /dev/null
+++ b/comms/ath3k-firmware/pkg-plist
@@ -0,0 +1,20 @@
+etc/devd/ath3k.conf
+%%DATADIR%%/ar3k/AthrBT_0x01020001.dfu
+%%DATADIR%%/ar3k/AthrBT_0x01020200.dfu
+%%DATADIR%%/ar3k/AthrBT_0x01020201.dfu
+%%DATADIR%%/ar3k/AthrBT_0x11020000.dfu
+%%DATADIR%%/ar3k/AthrBT_0x11020100.dfu
+%%DATADIR%%/ar3k/AthrBT_0x31010000.dfu
+%%DATADIR%%/ar3k/AthrBT_0x31010100.dfu
+%%DATADIR%%/ar3k/AthrBT_0x41020000.dfu
+%%DATADIR%%/ar3k/ramps_0x01020001_26.dfu
+%%DATADIR%%/ar3k/ramps_0x01020200_26.dfu
+%%DATADIR%%/ar3k/ramps_0x01020200_40.dfu
+%%DATADIR%%/ar3k/ramps_0x01020201_26.dfu
+%%DATADIR%%/ar3k/ramps_0x01020201_40.dfu
+%%DATADIR%%/ar3k/ramps_0x11020000_40.dfu
+%%DATADIR%%/ar3k/ramps_0x11020100_40.dfu
+%%DATADIR%%/ar3k/ramps_0x31010000_40.dfu
+%%DATADIR%%/ar3k/ramps_0x31010100_40.dfu
+%%DATADIR%%/ar3k/ramps_0x41020000_40.dfu
+%%DATADIR%%/ath3k-1.fw