aboutsummaryrefslogtreecommitdiff
path: root/converters/gbase/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'converters/gbase/Makefile')
-rw-r--r--converters/gbase/Makefile35
1 files changed, 29 insertions, 6 deletions
diff --git a/converters/gbase/Makefile b/converters/gbase/Makefile
index 0173688cbad9..19d2ad8969ea 100644
--- a/converters/gbase/Makefile
+++ b/converters/gbase/Makefile
@@ -7,17 +7,40 @@
PORTNAME= gbase
PORTVERSION= 0.5
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= converters
-MASTER_SITES= http://www.hibernaculum.net/download/
+MASTER_SITES= http://www.fluxcode.net/
MAINTAINER= ports@FreeBSD.org
COMMENT= A program to convert between the 4 common bases used in programming
-PLIST_FILES= bin/gbase
-USE_GNOME= gtk12
+OPTIONS= GTK2 "GTK+-2 support" off
+
+USE_GNOME= pkgconfig
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GTK2)
+USE_GNOME+= gtk12
+GTK_CFLAGS= `pkg-config --cflags gtk+-2.0`
+GTK_LIBS= `pkg-config --libs gtk+-2.0`
+.else
+USE_GNOME+= gtk12
+GTK_CFLAGS= `pkg-config --cflags gtk+`
+GTK_LIBS= `pkg-config --libs gtk+`
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|(i == argc)|(i+1 == argc)|' ${WRKSRC}/${PORTNAME}.c
+
+do-build:
+ cd ${WRKSRC}; ${CC} ${CFLAGS} ${GTK_CFLAGS} ${PORTNAME}.c \
+ -o ${PORTNAME} ${GTK_LIBS}
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/gbase ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>