aboutsummaryrefslogtreecommitdiff
path: root/converters/kdesupport11/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'converters/kdesupport11/Makefile')
-rw-r--r--converters/kdesupport11/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/converters/kdesupport11/Makefile b/converters/kdesupport11/Makefile
new file mode 100644
index 000000000000..c11861d44b0d
--- /dev/null
+++ b/converters/kdesupport11/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: kdesupport
+# Version required: Beta1
+# Date created: 28 October 1997
+# Whom: Stefan Eßer <se@freebsd.org>
+#
+# $Id: Makefile,v 1.1.1.1 1997/11/03 00:36:01 se Exp $
+#
+
+DISTNAME= kdesupport-Beta3-1
+PKGNAME= kdesupport-3.1b
+CATEGORIES= x11 kde
+MASTER_SITES= ftp://ftp.net.lut.ac.uk/kde/stable/Beta3/distribution/tgz/source/ \
+ ftp://ftp.uni-erlangen.de/pub/Linux/MIRROR.KDE/stable/Beta3/distribution/tgz/source/ \
+ ftp://ftp.caldera.com/pub/mirrors/kde/stable/Beta3/distribution/tgz/source/
+EXTRACT_SUFX= .src.tar.gz
+
+MAINTAINER= se@freebsd.org
+
+BUILD_DEPENDS= moc:${PORTSDIR}/x11/qt
+LIB_DEPENDS= qt\\.1\\.3[1-9]:${PORTSDIR}/x11/qt
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
+ "--without-libjpeg" \
+ "--without-libgif" \
+ "--without-libgdbm" \
+ "--without-libuulib" \
+# "--with-extra-includes=$(PREFIX)/include/giflib"
+CONFIGURE_ENV= CXXFLAGS="$(CFLAGS)" \
+ INSTALL_SCRIPT="install -c -m 555"
+
+WRKSRC= ${WRKDIR}/kdesupport
+
+.include <bsd.port.mk>