aboutsummaryrefslogtreecommitdiff
path: root/converters/libb64/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'converters/libb64/Makefile')
-rw-r--r--converters/libb64/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/converters/libb64/Makefile b/converters/libb64/Makefile
new file mode 100644
index 000000000000..b8b764cea302
--- /dev/null
+++ b/converters/libb64/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: libb64
+# Date created: 5 April 2012
+# Whom: Ismail Yenigul <ismail.yenigul@surgate.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libb64
+PORTVERSION= 1.2
+CATEGORIES= converters mail
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}.src
+
+MAINTAINER= ismail.yenigul@surgate.com
+COMMENT= A library of ANSI C routines for fast encoding/decoding data
+
+BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_ZIP= yes
+USE_GMAKE= yes
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/src/libb64.a ${PREFIX}/lib
+ ${MKDIR} ${PREFIX}/include/b64
+ ${INSTALL_DATA} ${WRKSRC}/include/b64/*.h ${PREFIX}/include/b64
+
+.include <bsd.port.mk>