aboutsummaryrefslogtreecommitdiff
path: root/converters/p5-Net-IDN-Nameprep/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'converters/p5-Net-IDN-Nameprep/Makefile')
-rw-r--r--converters/p5-Net-IDN-Nameprep/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/converters/p5-Net-IDN-Nameprep/Makefile b/converters/p5-Net-IDN-Nameprep/Makefile
new file mode 100644
index 000000000000..d91603634fcc
--- /dev/null
+++ b/converters/p5-Net-IDN-Nameprep/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Net-IDN-Nameprep
+# Date created: 10 Dec 2010
+# Whom: Timur Bakeyev <bat@cpan.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-IDN-Nameprep
+PORTVERSION= 1.100
+CATEGORIES= converters perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= timur@FreeBSD.org
+COMMENT= normalization of domain names (Nameprep, RFC 3491)
+
+RUN_DEPENDS= ${SITE_PERL}/Unicode/Stringprep.pm:${PORTSDIR}/converters/p5-Unicode-Stringprep
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ ${SITE_PERL}/Test/NoWarnings.pm:${PORTSDIR}/devel/p5-Test-NoWarnings
+
+PERL_MODBUILD= yes
+
+MAN3= Net::IDN::Nameprep.3
+
+.include <bsd.port.mk>