aboutsummaryrefslogtreecommitdiff
path: root/converters/xunicode/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'converters/xunicode/Makefile')
-rw-r--r--converters/xunicode/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/converters/xunicode/Makefile b/converters/xunicode/Makefile
new file mode 100644
index 000000000000..a8b8c307d167
--- /dev/null
+++ b/converters/xunicode/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: XUnicode
+# Date created: 25 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xunicode
+PORTVERSION= 0.2.7
+CATEGORIES= converters x11
+MASTER_SITES= http://www.ab.wakwak.com/~tino/jatk/
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_X_PREFIX= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-patch:
+ ${PERL} -i -pe 's,/usr/X11R6\b,${X11BASE},g' ${WRKSRC}/MakeInclude
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/lib/libxunicode.a ${PREFIX}/lib/
+ ${MKDIR} ${PREFIX}/include/xunicode
+ ${INSTALL_DATA} ${WRKSRC}/include/*.h ${PREFIX}/include/xunicode/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/xunicode/ja/
+ ${INSTALL_DATA} ${WRKSRC}/README.utf8 ${PREFIX}/share/doc/xunicode/ja/
+.endif
+
+.include <bsd.port.mk>