aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
Diffstat (limited to 'converters')
-rw-r--r--converters/Makefile1
-rw-r--r--converters/p5-JSON-MaybeXS/Makefile30
-rw-r--r--converters/p5-JSON-MaybeXS/distinfo2
-rw-r--r--converters/p5-JSON-MaybeXS/pkg-descr8
-rw-r--r--converters/p5-JSON-MaybeXS/pkg-plist6
5 files changed, 47 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index a4b35a393369..519c1ea6bf41 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -88,6 +88,7 @@
SUBDIR += p5-JSON
SUBDIR += p5-JSON-Any
SUBDIR += p5-JSON-DWIW
+ SUBDIR += p5-JSON-MaybeXS
SUBDIR += p5-JSON-PP
SUBDIR += p5-JSON-XS
SUBDIR += p5-JSON-XS-VersionOneAndTwo
diff --git a/converters/p5-JSON-MaybeXS/Makefile b/converters/p5-JSON-MaybeXS/Makefile
new file mode 100644
index 000000000000..1db52374c9e3
--- /dev/null
+++ b/converters/p5-JSON-MaybeXS/Makefile
@@ -0,0 +1,30 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= JSON-MaybeXS
+PORTVERSION= 1.000000
+CATEGORIES= converters perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Use Cpanel::JSON::XS with a fallback to JSON::PP
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Cpanel-JSON-XS>=2.33.10:${PORTSDIR}/converters/p5-Cpanel-JSON-XS
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Without-Module>=0.17:${PORTSDIR}/devel/p5-Test-Without-Module
+
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501800
+BUILD_DEPENDS+= p5-JSON-PP>=2.27202:${PORTSDIR}/converters/p5-JSON-PP
+RUN_DEPENDS+= p5-JSON-PP>=2.27202:${PORTSDIR}/converters/p5-JSON-PP
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/converters/p5-JSON-MaybeXS/distinfo b/converters/p5-JSON-MaybeXS/distinfo
new file mode 100644
index 000000000000..73fdaf88bb29
--- /dev/null
+++ b/converters/p5-JSON-MaybeXS/distinfo
@@ -0,0 +1,2 @@
+SHA256 (JSON-MaybeXS-1.000000.tar.gz) = a8dd97d144e2077f112493da7b28f5783e1042335703cf71a03705b9ef2419a0
+SIZE (JSON-MaybeXS-1.000000.tar.gz) = 4143
diff --git a/converters/p5-JSON-MaybeXS/pkg-descr b/converters/p5-JSON-MaybeXS/pkg-descr
new file mode 100644
index 000000000000..4d3d65e53a04
--- /dev/null
+++ b/converters/p5-JSON-MaybeXS/pkg-descr
@@ -0,0 +1,8 @@
+JSON::MaybeXS tries to load Cpanel::JSON::XS, and if that fails instead tries to
+load JSON::PP. If neither is available, an exception will be thrown.
+
+It then exports the encode_json and decode_json functions from the loaded
+module, along with a JSON constant that returns the class name for calling new
+on.
+
+WWW: http://search.cpan.org/dist/JSON-MaybeXS/
diff --git a/converters/p5-JSON-MaybeXS/pkg-plist b/converters/p5-JSON-MaybeXS/pkg-plist
new file mode 100644
index 000000000000..dfb9b825678c
--- /dev/null
+++ b/converters/p5-JSON-MaybeXS/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/JSON/MaybeXS.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/MaybeXS/.packlist
+%%PERL5_MAN3%%/JSON::MaybeXS.3.gz
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/MaybeXS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON
+@dirrmtry %%SITE_PERL%%/JSON