aboutsummaryrefslogtreecommitdiff
path: root/databases/adstudio/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/adstudio/Makefile')
-rw-r--r--databases/adstudio/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/databases/adstudio/Makefile b/databases/adstudio/Makefile
index 4422667036ab..4a9bdf49d012 100644
--- a/databases/adstudio/Makefile
+++ b/databases/adstudio/Makefile
@@ -6,17 +6,20 @@
#
PORTNAME= adstudio
-PORTVERSION= 4.0
+PORTVERSION= 4.5.2
+PORTREVISION= 1
CATEGORIES= databases devel java
MASTER_SITES= http://aquafold.fileburst.com/download/linux/
DISTNAME= ${PORTNAME}-novm
-DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}_${PORTREVISION}
MAINTAINER= thierry@FreeBSD.org
COMMENT= A database query and administration tool
+RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
+
USE_JAVA= yes
-JAVA_VERSION= 1.4
+JAVA_VERSION= 1.4+
NO_BUILD= yes
USE_REINPLACE= yes
@@ -30,7 +33,8 @@ INSTFILES= License.txt PAD_FILE.XML changelog.txt datastudio.gif \
pre-configure:
${REINPLACE_CMD} -e "s|%%ADS_HOME%%|${DATADIR}|" \
- -e "s|^java |${JAVA} -Xmx256M |" ${WRKSRC}/datastudio.sh
+ -e "s|^java |JAVA_VERSION=${JAVA_VERSION} ${LOCALBASE}/bin/java -Xmx256M |" \
+ ${WRKSRC}/datastudio.sh
do-install:
${MKDIR} ${DATADIR}