aboutsummaryrefslogtreecommitdiff
path: root/databases/courier-authlib-userdb/files
diff options
context:
space:
mode:
Diffstat (limited to 'databases/courier-authlib-userdb/files')
-rw-r--r--databases/courier-authlib-userdb/files/courier-authdaemond.sh44
-rw-r--r--databases/courier-authlib-userdb/files/patch-Makefile.in13
-rw-r--r--databases/courier-authlib-userdb/files/patch-ldap13
-rw-r--r--databases/courier-authlib-userdb/files/patch-liblog::Makefile.in13
-rw-r--r--databases/courier-authlib-userdb/files/patch-mysql182
-rw-r--r--databases/courier-authlib-userdb/files/patch-userdb::Makefile.in13
6 files changed, 0 insertions, 278 deletions
diff --git a/databases/courier-authlib-userdb/files/courier-authdaemond.sh b/databases/courier-authlib-userdb/files/courier-authdaemond.sh
deleted file mode 100644
index b4af4c0b40fd..000000000000
--- a/databases/courier-authlib-userdb/files/courier-authdaemond.sh
+++ /dev/null
@@ -1,44 +0,0 @@
-#!/bin/sh
-#
-# An rc.subr-style startup script for courier-authdaemond service.
-
-# PROVIDE: courier_authdaemond
-# REQUIRE: LOGIN
-# KEYWORD: FreeBSD shutdown
-
-# Define these courier_authdaemond_* variables in one of these files:
-# /etc/rc.conf
-# /etc/rc.conf.local
-# /etc/rc.conf.d/courier_authdaemond
-#
-# DO NOT CHANGE THESE DEFAULT VALUES HERE
-
-courier_authdaemond_enable=${courier_authdaemond_enable-"NO"}
-
-. %%RC_SUBR%%
-
-name="courier_authdaemond"
-rcvar=`set_rcvar`
-command="%%PREFIX%%/sbin/authdaemond"
-
-start_cmd="authdaemond_cmd start"
-stop_cmd="authdaemond_cmd stop"
-restart_cmd="authdaemond_cmd stop && authdaemond_cmd start"
-
-load_rc_config $name
-
-authdaemond_cmd () {
- case $1 in
- start)
- echo "Starting ${name}."
- ${command} start
- ;;
- stop)
- echo "Stopping ${name}."
- ${command} stop
- ;;
- esac
-}
-
-run_rc_command "$1"
-
diff --git a/databases/courier-authlib-userdb/files/patch-Makefile.in b/databases/courier-authlib-userdb/files/patch-Makefile.in
deleted file mode 100644
index 03046540f679..000000000000
--- a/databases/courier-authlib-userdb/files/patch-Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.in.orig Sat Dec 18 17:25:16 2004
-+++ Makefile.in Sat Dec 18 17:27:50 2004
-@@ -992,8 +992,8 @@
- inst=`echo $$i | sed -e 's/\\.[0-9a-z]*$$//'`; \
- inst=`echo $$inst | sed -e 's/^.*\///'`; \
- inst=`echo $$inst | sed '$(transform)'`.$$ext; \
-- echo " $(INSTALL_DATA) '$$file' '$(DESTDIR)$(man3dir)/$$inst'"; \
-- $(INSTALL_DATA) "$$file" "$(DESTDIR)$(man3dir)/$$inst"; \
-+ echo " %%INSTALL_MAN%% '$$file' '$(DESTDIR)$(man3dir)/$$inst'"; \
-+ %%INSTALL_MAN%% "$$file" "$(DESTDIR)$(man3dir)/$$inst"; \
- done
- uninstall-man3:
- @$(NORMAL_UNINSTALL)
diff --git a/databases/courier-authlib-userdb/files/patch-ldap b/databases/courier-authlib-userdb/files/patch-ldap
deleted file mode 100644
index 1cae12242d67..000000000000
--- a/databases/courier-authlib-userdb/files/patch-ldap
+++ /dev/null
@@ -1,13 +0,0 @@
---- configure.orig Wed Mar 3 05:54:13 2004
-+++ configure Tue Mar 16 19:36:40 2004
-@@ -1268,6 +1268,10 @@
- { (exit 1); exit 1; }; }
- fi
-
-+CFLAGS="$CFLAGS -I%%LOCALBASE%%/include"
-+CPPFLAGS="$CPPFLAGS -I%%LOCALBASE%%/include"
-+LDFLAGS="-L%%LOCALBASE%%/lib $LDFLAGS"
-+
- ac_ext=c
- ac_cpp='$CPP $CPPFLAGS'
- ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
diff --git a/databases/courier-authlib-userdb/files/patch-liblog::Makefile.in b/databases/courier-authlib-userdb/files/patch-liblog::Makefile.in
deleted file mode 100644
index 301ba9c2efba..000000000000
--- a/databases/courier-authlib-userdb/files/patch-liblog::Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- liblog/Makefile.in.orig Sat Dec 18 18:31:57 2004
-+++ liblog/Makefile.in Sat Dec 18 18:32:18 2004
-@@ -346,8 +346,8 @@
- inst=`echo $$i | sed -e 's/\\.[0-9a-z]*$$//'`; \
- inst=`echo $$inst | sed -e 's/^.*\///'`; \
- inst=`echo $$inst | sed '$(transform)'`.$$ext; \
-- echo " $(INSTALL_DATA) '$$file' '$(DESTDIR)$(man1dir)/$$inst'"; \
-- $(INSTALL_DATA) "$$file" "$(DESTDIR)$(man1dir)/$$inst"; \
-+ echo " %%INSTALL_MAN%% '$$file' '$(DESTDIR)$(man1dir)/$$inst'"; \
-+ %%INSTALL_MAN%% "$$file" "$(DESTDIR)$(man1dir)/$$inst"; \
- done
- uninstall-man1:
- @$(NORMAL_UNINSTALL)
diff --git a/databases/courier-authlib-userdb/files/patch-mysql b/databases/courier-authlib-userdb/files/patch-mysql
deleted file mode 100644
index 17f6042e3a47..000000000000
--- a/databases/courier-authlib-userdb/files/patch-mysql
+++ /dev/null
@@ -1,182 +0,0 @@
---- configure.orig Sat Dec 18 17:28:54 2004
-+++ configure Sat Dec 18 17:30:51 2004
-@@ -23821,9 +23821,9 @@
- if test "$doauthmysql" = ""
- then
- LIBS="$MYSQL_LIBS $LIBS"
-- echo "$as_me:$LINENO: checking for mysql_connect" >&5
--echo $ECHO_N "checking for mysql_connect... $ECHO_C" >&6
--if test "${ac_cv_func_mysql_connect+set}" = set; then
-+ echo "$as_me:$LINENO: checking for mysql_real_connect" >&5
-+echo $ECHO_N "checking for mysql_real_connect... $ECHO_C" >&6
-+if test "${ac_cv_func_mysql_real_connect+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- cat >conftest.$ac_ext <<_ACEOF
-@@ -23832,12 +23832,12 @@
- cat confdefs.h >>conftest.$ac_ext
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
--/* Define mysql_connect to an innocuous variant, in case <limits.h> declares mysql_connect.
-+/* Define mysql_real_connect to an innocuous variant, in case <limits.h> declares mysql_real_connect.
- For example, HP-UX 11i <limits.h> declares gettimeofday. */
--#define mysql_connect innocuous_mysql_connect
-+#define mysql_real_connect innocuous_mysql_real_connect
-
- /* System header to define __stub macros and hopefully few prototypes,
-- which can conflict with char mysql_connect (); below.
-+ which can conflict with char mysql_real_connect (); below.
- Prefer <limits.h> to <assert.h> if __STDC__ is defined, since
- <limits.h> exists even on freestanding compilers. */
-
-@@ -23847,7 +23847,7 @@
- # include <assert.h>
- #endif
-
--#undef mysql_connect
-+#undef mysql_real_connect
-
- /* Override any gcc2 internal prototype to avoid an error. */
- #ifdef __cplusplus
-@@ -23856,14 +23856,14 @@
- #endif
- /* We use char because int might match the return type of a gcc2
- builtin and then its argument prototype would still apply. */
--char mysql_connect ();
-+char mysql_real_connect ();
- /* The GNU C library defines this for functions which it implements
- to always fail with ENOSYS. Some functions are actually named
- something starting with __ and the normal name is an alias. */
--#if defined (__stub_mysql_connect) || defined (__stub___mysql_connect)
-+#if defined (__stub_mysql_real_connect) || defined (__stub___mysql_real_connect)
- choke me
- #else
--char (*f) () = mysql_connect;
-+char (*f) () = mysql_real_connect;
- #endif
- #ifdef __cplusplus
- }
-@@ -23872,7 +23872,7 @@
- int
- main ()
- {
--return f != mysql_connect;
-+return f != mysql_real_connect;
- ;
- return 0;
- }
-@@ -23899,19 +23899,19 @@
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
-- ac_cv_func_mysql_connect=yes
-+ ac_cv_func_mysql_real_connect=yes
- else
- echo "$as_me: failed program was:" >&5
- sed 's/^/| /' conftest.$ac_ext >&5
-
--ac_cv_func_mysql_connect=no
-+ac_cv_func_mysql_real_connect=no
- fi
- rm -f conftest.err conftest.$ac_objext \
- conftest$ac_exeext conftest.$ac_ext
- fi
--echo "$as_me:$LINENO: result: $ac_cv_func_mysql_connect" >&5
--echo "${ECHO_T}$ac_cv_func_mysql_connect" >&6
--if test $ac_cv_func_mysql_connect = yes; then
-+echo "$as_me:$LINENO: result: $ac_cv_func_mysql_real_connect" >&5
-+echo "${ECHO_T}$ac_cv_func_mysql_real_connect" >&6
-+if test $ac_cv_func_mysql_real_connect = yes; then
- doauthmysql="yes"
-
- fi
-@@ -24021,9 +24021,9 @@
- else
- saveLIBS="$LIBS"
- LIBS="$MYSQL_LIBS $LIBS"
-- echo "$as_me:$LINENO: checking for mysql_connect" >&5
--echo $ECHO_N "checking for mysql_connect... $ECHO_C" >&6
--if test "${ac_cv_func_mysql_connect+set}" = set; then
-+ echo "$as_me:$LINENO: checking for mysql_real_connect" >&5
-+echo $ECHO_N "checking for mysql_real_connect... $ECHO_C" >&6
-+if test "${ac_cv_func_mysql_real_connect+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- cat >conftest.$ac_ext <<_ACEOF
-@@ -24032,12 +24032,12 @@
- cat confdefs.h >>conftest.$ac_ext
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
--/* Define mysql_connect to an innocuous variant, in case <limits.h> declares mysql_connect.
-+/* Define mysql_real_connect to an innocuous variant, in case <limits.h> declares mysql_real_connect.
- For example, HP-UX 11i <limits.h> declares gettimeofday. */
--#define mysql_connect innocuous_mysql_connect
-+#define mysql_real_connect innocuous_mysql_real_connect
-
- /* System header to define __stub macros and hopefully few prototypes,
-- which can conflict with char mysql_connect (); below.
-+ which can conflict with char mysql_real_connect (); below.
- Prefer <limits.h> to <assert.h> if __STDC__ is defined, since
- <limits.h> exists even on freestanding compilers. */
-
-@@ -24047,7 +24047,7 @@
- # include <assert.h>
- #endif
-
--#undef mysql_connect
-+#undef mysql_real_connect
-
- /* Override any gcc2 internal prototype to avoid an error. */
- #ifdef __cplusplus
-@@ -24056,14 +24056,14 @@
- #endif
- /* We use char because int might match the return type of a gcc2
- builtin and then its argument prototype would still apply. */
--char mysql_connect ();
-+char mysql_real_connect ();
- /* The GNU C library defines this for functions which it implements
- to always fail with ENOSYS. Some functions are actually named
- something starting with __ and the normal name is an alias. */
--#if defined (__stub_mysql_connect) || defined (__stub___mysql_connect)
-+#if defined (__stub_mysql_real_connect) || defined (__stub___mysql_real_connect)
- choke me
- #else
--char (*f) () = mysql_connect;
-+char (*f) () = mysql_real_connect;
- #endif
- #ifdef __cplusplus
- }
-@@ -24072,7 +24072,7 @@
- int
- main ()
- {
--return f != mysql_connect;
-+return f != mysql_real_connect;
- ;
- return 0;
- }
-@@ -24099,19 +24099,19 @@
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
-- ac_cv_func_mysql_connect=yes
-+ ac_cv_func_mysql_real_connect=yes
- else
- echo "$as_me: failed program was:" >&5
- sed 's/^/| /' conftest.$ac_ext >&5
-
--ac_cv_func_mysql_connect=no
-+ac_cv_func_mysql_real_connect=no
- fi
- rm -f conftest.err conftest.$ac_objext \
- conftest$ac_exeext conftest.$ac_ext
- fi
--echo "$as_me:$LINENO: result: $ac_cv_func_mysql_connect" >&5
--echo "${ECHO_T}$ac_cv_func_mysql_connect" >&6
--if test $ac_cv_func_mysql_connect = yes; then
-+echo "$as_me:$LINENO: result: $ac_cv_func_mysql_real_connect" >&5
-+echo "${ECHO_T}$ac_cv_func_mysql_real_connect" >&6
-+if test $ac_cv_func_mysql_real_connect = yes; then
- LIBAUTHMYSQL="libauthmysql.la"
- HAVE_AUTHMYSQL=1
- else
diff --git a/databases/courier-authlib-userdb/files/patch-userdb::Makefile.in b/databases/courier-authlib-userdb/files/patch-userdb::Makefile.in
deleted file mode 100644
index c4c62ce68aa3..000000000000
--- a/databases/courier-authlib-userdb/files/patch-userdb::Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- userdb/Makefile.in.orig Sat Dec 18 18:33:08 2004
-+++ userdb/Makefile.in Sat Dec 18 18:34:09 2004
-@@ -378,8 +378,8 @@
- inst=`echo $$i | sed -e 's/\\.[0-9a-z]*$$//'`; \
- inst=`echo $$inst | sed -e 's/^.*\///'`; \
- inst=`echo $$inst | sed '$(transform)'`.$$ext; \
-- echo " $(INSTALL_DATA) '$$file' '$(DESTDIR)$(man8dir)/$$inst'"; \
-- $(INSTALL_DATA) "$$file" "$(DESTDIR)$(man8dir)/$$inst"; \
-+ echo " %%INSTALL_MAN%% '$$file' '$(DESTDIR)$(man8dir)/$$inst'"; \
-+ %%INSTALL_MAN%% "$$file" "$(DESTDIR)$(man8dir)/$$inst"; \
- done
- uninstall-man8:
- @$(NORMAL_UNINSTALL)