aboutsummaryrefslogtreecommitdiff
path: root/databases/firebird-client
diff options
context:
space:
mode:
Diffstat (limited to 'databases/firebird-client')
-rw-r--r--databases/firebird-client/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/databases/firebird-client/Makefile b/databases/firebird-client/Makefile
index 486467c2efda..c0f4343a84d1 100644
--- a/databases/firebird-client/Makefile
+++ b/databases/firebird-client/Makefile
@@ -24,6 +24,7 @@ INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/firebird/lib
MSG_FILE= ${PKGDIR}/pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
+USE_REINPLACE= yes
ONLY_FOR_ARCHS= i386
@@ -43,10 +44,10 @@ do-extract:
post-patch:
@${SED} 's|%%PREFIX%%|${PREFIX}|g' ${MSG_FILE} > ${PKGMESSAGE}
.if ${OSVERSION} >= 500016 || ${OSVERSION} >= 430001
- @${PERL} -pi -e 's,\-ldescrypt,\-lcrypt,g' \
+ @${REINPLACE_CMD} -e 's,\-ldescrypt,\-lcrypt,g' \
${WRKSRC}/builds/original/prefix.freebsd
.else
- @${PERL} -pi -e 's,^crypt_set_format.*,,' ${WRKSRC}/jrd/enc.c
+ @${REINPLACE_CMD} -e 's,^crypt_set_format.*,,' ${WRKSRC}/jrd/enc.c
.endif
do-configure: