aboutsummaryrefslogtreecommitdiff
path: root/databases/firebird20-server
diff options
context:
space:
mode:
Diffstat (limited to 'databases/firebird20-server')
-rw-r--r--databases/firebird20-server/Makefile38
-rw-r--r--databases/firebird20-server/distinfo5
-rw-r--r--databases/firebird20-server/files/patch-builds%posix%make.defaults14
-rw-r--r--databases/firebird20-server/files/patch-configure.in58
-rw-r--r--databases/firebird20-server/files/pkg-message.in16
-rw-r--r--databases/firebird20-server/pkg-plist2
6 files changed, 74 insertions, 59 deletions
diff --git a/databases/firebird20-server/Makefile b/databases/firebird20-server/Makefile
index 3ae964fa7dc5..fa5ca6451f9c 100644
--- a/databases/firebird20-server/Makefile
+++ b/databases/firebird20-server/Makefile
@@ -6,16 +6,18 @@
#
PORTNAME?= firebird
-PORTVERSION= 2.0.3
-PORTREVISION= 6
+PORTVERSION= 2.0.6
CATEGORIES?= databases
MASTER_SITES= SF/firebird/OldFiles
PKGNAMESUFFIX?= -server
-DISTNAME= Firebird-2.0.3.12981-1
+DISTNAME= ${PORTNAME:S/f/F/}-${PORTVERSION}.13266-0
+DIST_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= acm@FreeBSD.org
COMMENT?= Firebird-2 relational database (server)
+LIB_DEPENDS= icuuc:${PORTSDIR}/devel/icu
+
LATEST_LINK= ${PORTNAME}20${PKGNAMESUFFIX}
USE_BISON= build
@@ -40,8 +42,8 @@ LD= ${CC}
STRIP=
ONLY_FOR_ARCHS= i386 amd64
-CONFLICTS+= firebird-client-1* firebird-server-1* \
- firebird-client-2.1* firebird-server-2.1*
+CONFLICTS+= firebird-client-2.1* firebird-server-2.1* \
+ firebird-client-2.5* firebird-server-2.5*
INSTALL_FB= ${INSTALL} ${COPY} -g firebird
@@ -53,7 +55,6 @@ IGNORE= your system does not support sysvipc
.if !defined(CLIENT_ONLY)
# Server part stuff
LIB_DEPENDS+= fbembed.2:${PORTSDIR}/databases/firebird20-client
-
AUTOGENARGS= --with-lock-manager
ALL_TARGET= firebird_boot ref_databases msgs libfbembed intl otherfiles \
@@ -62,19 +63,15 @@ ALL_TARGET= firebird_boot ref_databases msgs libfbembed intl otherfiles \
SUB_FILES= pkg-install pkg-message aliases.conf
-UTIL_BIN= fb_inet_server fb_lock_print gbak gdef gfix gsec gstat nbackup
+UTIL_BIN= fb_inet_server fb_lock_print fbstat gbak gdef gfix gsec nbackup
UDF_SO= ib_udf.so fbudf.so
UDF_SQL= src/extlib/ib_udf2.sql src/extlib/fbudf/fbudf.sql
.else
# Client part stuff
-LIB_DEPENDS= icuuc:${PORTSDIR}/devel/icu
-
AUTOGENARGS= --with-editline
ALL_TARGET= firebird_basic libfbembed embed_isql embed_gpre \
embed_gdef embed_qli libfbclient extlib
-#ALL_TARGET= firebird_basic libfbembed libfbclient \
-# client_gpre client_gdef client_isql client_qli extlib
USE_LDCONFIG= yes
CLIENT_BIN= gpre isql-fb qli
@@ -103,24 +100,13 @@ post-patch:
@${MKDIR} ${WRKSRC}/m4
${CP} ${FILESDIR}/*.m4 ${WRKSRC}/m4
${FIND} ${WRKSRC} -name "*.sh" -exec ${CHMOD} +x {} \+
-.if defined(CLIENT_ONLY)
- ${REINPLACE_CMD} -e 's|/isql|/isql-fb|g' ${WRKSRC}/builds/posix/make.defaults
-.endif
+ ${REINPLACE_CMD} -e \
+ 's|/isql|/isql-fb|g' -e \
+ 's|/gstat|/fbstat|g' ${WRKSRC}/builds/posix/make.defaults
.include <bsd.port.pre.mk>
.if !defined(CLIENT_ONLY)
-pre-everything::
- @${ECHO_MSG} "WARNING: The on-disk structure of the databases has"
- @${ECHO_MSG} "changed since version 1.x."
- @${ECHO_MSG} "Cancel this installation now and backup your databases"
- @${ECHO_MSG} "if you have not already done so."
-.if !defined(BATCH)
- @sleep 2
-.endif
-.endif
-
-.if !defined(CLIENT_ONLY)
pre-su-install:
@${SETENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
diff --git a/databases/firebird20-server/distinfo b/databases/firebird20-server/distinfo
index e08c0d85c12b..e95c6459f67f 100644
--- a/databases/firebird20-server/distinfo
+++ b/databases/firebird20-server/distinfo
@@ -1,3 +1,2 @@
-MD5 (Firebird-2.0.3.12981-1.tar.bz2) = 5c70e72c4a3e4689d4bae2cee2694991
-SHA256 (Firebird-2.0.3.12981-1.tar.bz2) = 2afe8411f844414f86ff93a66a75e542b78a1593019cc430a56ef27616885f00
-SIZE (Firebird-2.0.3.12981-1.tar.bz2) = 12627615
+SHA256 (firebird/Firebird-2.0.6.13266-0.tar.bz2) = 042a0a3f12959d68173d4a04f1b09c5cfd613d27d3341f445281d66e9a183761
+SIZE (firebird/Firebird-2.0.6.13266-0.tar.bz2) = 13134922
diff --git a/databases/firebird20-server/files/patch-builds%posix%make.defaults b/databases/firebird20-server/files/patch-builds%posix%make.defaults
index fa5cf46755f6..17237b28d4d3 100644
--- a/databases/firebird20-server/files/patch-builds%posix%make.defaults
+++ b/databases/firebird20-server/files/patch-builds%posix%make.defaults
@@ -1,6 +1,6 @@
---- builds/posix/make.defaults.orig 2007-09-04 15:51:17.000000000 +0800
-+++ builds/posix/make.defaults 2007-10-05 07:05:13.947441166 +0800
-@@ -107,7 +107,7 @@
+--- builds/posix/make.defaults 2008-09-04 06:50:16.000000000 -0500
++++ builds/posix/make.defaults 2010-12-18 15:37:24.000000000 -0500
+@@ -109,7 +109,7 @@
CHMOD= chmod
CHMOD_6= chmod 666
CHMOD_7= chmod 777
@@ -9,7 +9,7 @@
MV= mv -f
TOUCH= touch
CP= cp
-@@ -185,9 +185,6 @@
+@@ -187,9 +187,6 @@
LIBFBSTATIC_A = $(LIB)/libfbstatic.a
LIBEDITLINE_A = $(LIB)/libeditline.a
@@ -19,12 +19,12 @@
# Shared library name for usage inside of the UDF
IbUtilLibraryName = $(LIB_PREFIX)ib_util.$(SHRLIB_EXT)
-@@ -203,7 +200,7 @@
+@@ -205,7 +202,7 @@
STATICEXE_LINK:= @CXX@
- LINK_LIBS = @LIBS@ @EDITLINE_A@
+ LINK_LIBS = @EDITLINE_A@ @LIBS@
-ICU_LIBS = -licuuc -licudata -licui18n
+ICU_LIBS = @ICU_LIBS@ @ICU_LDFLAGS@
- STATICLINK_LIBS = @LIBS@ @EDITLINE_A@
+ STATICLINK_LIBS = @EDITLINE_A@ @LIBS@
SO_LINK_LIBS = @LIBS@
diff --git a/databases/firebird20-server/files/patch-configure.in b/databases/firebird20-server/files/patch-configure.in
index 8d7ab74a0f64..9ef92d7e5c59 100644
--- a/databases/firebird20-server/files/patch-configure.in
+++ b/databases/firebird20-server/files/patch-configure.in
@@ -1,26 +1,52 @@
---- configure.in.orig 2007-09-04 15:51:12.000000000 +0800
-+++ configure.in 2009-11-07 17:47:35.000000000 +0100
-@@ -447,8 +447,9 @@
- AC_CHECK_LIB(termcap, tgetent, , \
- AC_CHECK_LIB(tinfo, tgetent, , \
+--- configure.in 2009-03-06 13:27:05.000000000 -0500
++++ configure.in 2010-12-18 18:01:10.000000000 -0500
+@@ -72,6 +72,7 @@
+ PLATFORM=FREEBSD
+ AC_DEFINE(FREEBSD, 1, [Define this if OS is FreeBSD])
+ AC_DEFINE(AMD64, 1, [Define this if CPU is amd64])
++ XE_APPEND(-lreadline,LIBS)
+ LOCK_MANAGER_FLG=Y
+ EDITLINE_FLG=Y
+ SHRLIB_EXT=so
+@@ -90,6 +91,7 @@
+ MAKEFILE_PREFIX=freebsd
+ PLATFORM=FREEBSD
+ AC_DEFINE(FREEBSD, 1, [Define this if OS is FreeBSD])
++ XE_APPEND(-lreadline,LIBS)
+ LOCK_MANAGER_FLG=Y
+ EDITLINE_FLG=Y
+ SHRLIB_EXT=so
+@@ -473,6 +475,7 @@
+ AC_CHECK_HEADERS(socket.h sys/socket.h sys/sockio.h winsock2.h)
+ AC_CHECK_HEADERS(sys/sem.h)
+ AC_CHECK_HEADERS(semaphore.h)
++AC_CHECK_HEADERS(sys/resource.h)
+
+ dnl Check for libraries
+ AC_CHECK_LIB(dl, main)
+@@ -484,10 +487,11 @@
+ AC_CHECK_LIB(termcap, tgetent, TERMLIB=termcap, \
+ AC_CHECK_LIB(tinfo, tgetent, TERMLIB=tinfo, \
AC_MSG_ERROR(termcap support not found)))))
- AC_SUBST(EDITLINE_A, -leditline)
-+ AC_SUBST(EDITLINE_A, "-ledit -lreadline")
++ AC_SUBST(EDITLINE_A, -ledit -leditline)
+ AC_SUBST(TERMLIB)
+ XE_APPEND(-l$TERMLIB, LIBS)
fi
+AM_PATH_ICU(3, 6)
-
- dnl Check for functions
-@@ -696,7 +696,7 @@
+ dnl check for va_copy() in stdarg.h
+ dnl _ISOC99_SOURCE is defined to emulate C++ compilation in plain-C conftest.c
+@@ -776,7 +780,7 @@
rm -f conftest*])
if test "$firebird_cv_gcc___thread" = yes; then
- AC_DEFINE(HAVE___THREAD, 1, [Define it if compiler supports ISO syntax for thread-local storage])
-+dnl AC_DEFINE(HAVE___THREAD, 1, [Define it if compiler supports ISO syntax for thread-local storage])
++ dnl AC_DEFINE(HAVE___THREAD, 1, [Define it if compiler supports ISO syntax for thread-local storage])
fi
dnl ##################### DO NOT ADD ANY TESTS BELOW ###########################
-@@ -720,6 +721,10 @@
+@@ -802,6 +806,10 @@
AC_SUBST(NEW_FIREBIRD_DIR)
AC_DEFINE_UNQUOTED(FB_PREFIX, $(if test "x$prefix" = "xNONE" ; then echo \"$ac_default_prefix\"; else echo \"$prefix\"; fi), [Installation path prefix])
@@ -31,14 +57,17 @@
AC_CONFIG_COMMANDS(,,[
dnl # rebuild version header if needed
-@@ -1048,19 +1053,11 @@
+@@ -1161,7 +1169,6 @@
gen/Makefile.install:builds/install/arch-specific/${INSTALL_PREFIX}/Makefile.in
Makefile:Makefile.in
gen/Makefile.extern.editline:${MAKE_SRC_DIR}/Makefile.in.extern.editline
-gen/Makefile.extern.icu:${MAKE_SRC_DIR}/Makefile.in.extern.icu
)
-
+ case "$PLATFORM" in
+@@ -1172,15 +1179,7 @@
+ ;;
+ esac
-if test "$PROD_BUILD_FLG" = N; then
- DEBUG_ICU=--enable-debug
@@ -48,6 +77,7 @@
-(cd extern/icu/source
-chmod +x runConfigureICU configure install-sh
-./runConfigureICU "$ICU_PLATFORM" "$DEBUG_ICU" --prefix=`pwd`/..)
-
+-
dnl Print out the build configuration (the most interesting thing)
+ echo
diff --git a/databases/firebird20-server/files/pkg-message.in b/databases/firebird20-server/files/pkg-message.in
index 94d4194294b8..3d098ff99886 100644
--- a/databases/firebird20-server/files/pkg-message.in
+++ b/databases/firebird20-server/files/pkg-message.in
@@ -1,18 +1,18 @@
+###############################################################################
----------------------------------------------------------
-Firebird is now installed.
+Firebird was installed.
-Before start the server ensure that the following line exists in /etc/services:
+1) Before start the server ensure that the following line exists in /etc/services:
gds_db 3050/tcp #InterBase Database Remote Protocol
-If you use inetd then add the following line to /etc/inetd.conf
+2) If you use inetd then add the following line to /etc/inetd.conf
gds_db stream tcp nowait firebird %%PREFIX%%/bin/fb_inet_server fb_inet_server
And finally restart inetd.
-It is STRONGLY recommended that you change the SYSDBA
+3) It is STRONGLY recommended that you change the SYSDBA
password with:
% gsec -user SYSDBA -pass masterkey
@@ -21,7 +21,7 @@ GSEC> quit
before doing anything serious with Firebird.
-See documentation in %%DOCSDIR%%/
-for more information.
----------------------------------------------------------
+4) See documentation in %%DOCSDIR%%/ for more information.
+5) Enjoy it ;)
+################################################################################
diff --git a/databases/firebird20-server/pkg-plist b/databases/firebird20-server/pkg-plist
index ad1998718589..e52eb5039c5c 100644
--- a/databases/firebird20-server/pkg-plist
+++ b/databases/firebird20-server/pkg-plist
@@ -2,12 +2,12 @@
bin/fb_inet_server
bin/fb_lock_mgr
bin/fb_lock_print
+bin/fbstat
bin/gbak
bin/gdef
bin/gds_drop
bin/gfix
bin/gsec
-bin/gstat
bin/nbackup
libexec/firebird/intl/fbintl
libexec/firebird/intl/fbintl.conf