aboutsummaryrefslogtreecommitdiff
path: root/databases/kinterbasdb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/kinterbasdb/Makefile')
-rw-r--r--databases/kinterbasdb/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/databases/kinterbasdb/Makefile b/databases/kinterbasdb/Makefile
index 02a1f0c2fb20..b167fe338565 100644
--- a/databases/kinterbasdb/Makefile
+++ b/databases/kinterbasdb/Makefile
@@ -24,9 +24,13 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_PYTHON_PREFIX= yes
-
+USE_REINPLACE= yes
USE_GCC= 3.4
PLIST_SUB= INSTALLDIR=lib/${PYTHON_VERSION}/site-packages/${PORTNAME}
+post-extract:
+ @${REINPLACE_CMD} -e "s@DEFAULT_FREEBSD_HOME_DIR = '.*'@DEFAULT_FREEBSD_HOME_DIR = '${LOCALBASE}'@" \
+ ${WRKSRC}/setup.py
+
.include <bsd.port.mk>