aboutsummaryrefslogtreecommitdiff
path: root/databases/libdbi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/libdbi/Makefile')
-rw-r--r--databases/libdbi/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/databases/libdbi/Makefile b/databases/libdbi/Makefile
new file mode 100644
index 000000000000..fdd703b816bd
--- /dev/null
+++ b/databases/libdbi/Makefile
@@ -0,0 +1,42 @@
+# ex:ts=8
+# New ports collection makefile for: libdbi
+# Date created: Nov 4, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libdbi
+PORTVERSION= 0.6.2
+CATEGORIES= databases devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://linux.ucla.edu/~dap24/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+PLIST_SUB= VERSION=${PORTVERSION}
+
+.if defined(WITH_PGSQL)
+LIB_DEPENDS+= pq:${PORTSDIR}/databases/postgresql7
+CONFIGURE_ARGS+= --with-pgsql
+PLIST_SUB+= WITH_PQ=""
+.else
+PLIST_SUB+= WITH_PQ="@comment "
+.endif
+
+.if defined(WITH_MYSQL)
+LIB_DEPENDS+= mysqlclient:${PORTSDIR}/databases/mysql323-client
+CONFIGURE_ARGS+= \
+ --with-mysql \
+ --with-mysql-incdir=${LOCALBASE}/include \
+ --with-mysql-libdir=${LOCALBASE}/lib/mysql
+PLIST_SUB+= WITH_MY=""
+.else
+PLIST_SUB+= WITH_MY="@comment "
+.endif
+
+.include <bsd.port.mk>