aboutsummaryrefslogtreecommitdiff
path: root/databases/mariadb101-client/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/mariadb101-client/Makefile')
-rw-r--r--databases/mariadb101-client/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/databases/mariadb101-client/Makefile b/databases/mariadb101-client/Makefile
index 57474bab9f36..3930e76262fe 100644
--- a/databases/mariadb101-client/Makefile
+++ b/databases/mariadb101-client/Makefile
@@ -18,9 +18,10 @@ USE_LDCONFIG= ${PREFIX}/lib/mysql
CLIENT_ONLY= yes
-post-install:
+post-stage:
${RM} ${STAGEDIR}${PREFIX}/share/aclocal/mysql.m4
${RM} -r ${STAGEDIR}${PREFIX}/share/pkgconfig
+ ${RM} -r ${STAGEDIR}${PREFIX}/include/mysql/private
. for b in mysql mysqladmin mysqlbinlog mysqlcheck mysqldump \
mysqlimport mysqlshow mysqlslap
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${b}
@@ -32,7 +33,7 @@ post-install:
# Fix https://mariadb.atlassian.net/browse/MDEV-9388
@${REINPLACE_CMD} 's/-l-pthread/-lpthread/' ${STAGEDIR}${PREFIX}/bin/mysql_config
-post-install-GSSAPI_NONE:
+post-stage-GSSAPI_NONE:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/mysql/plugin/auth_gssapi_client.so
.include "${MASTERDIR}/Makefile"