aboutsummaryrefslogtreecommitdiff
path: root/databases/memcached/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/memcached/Makefile')
-rw-r--r--databases/memcached/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/databases/memcached/Makefile b/databases/memcached/Makefile
index a019f7bdeb4d..abc84e170e26 100644
--- a/databases/memcached/Makefile
+++ b/databases/memcached/Makefile
@@ -3,6 +3,7 @@
PORTNAME= memcached
PORTVERSION= 1.4.33
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://www.memcached.org/files/ \
GENTOO
@@ -19,7 +20,16 @@ CONFLICTS= memcached-1.2*
# Dtrace option disabled until it is fixed upstream
OPTIONS_DEFINE= SASL DOCS DTRACE
-OPTIONS_DEFAULT= SASL
+OPTIONS_DEFAULT= SASL DTRACE
+
+.if !exists(/usr/sbin/dtrace)
+OPTIONS_EXCLUDE+= DTRACE
+.endif
+
+OPTIONS_EXCLUDE_FreeBSD_9+= DTRACE
+OPTIONS_EXCLUDE_FreeBSD_10+= DTRACE
+OPTIONS_EXCLUDE+= ${OPTIONS_EXCLUDE_${OPSYS}_${OSREL:R}}
+OPTIONS_EXCLUDE_i386= DTRACE
DTRACE_DESC= Enable dtrace probes
SASL_DESC= Enable SASL Authentication
@@ -55,8 +65,9 @@ MAKE_JOBS_UNSAFE= yes
CONFIGURE_ARGS+= --enable-64bit
.endif
+# avoid triggering a bug in libdtrace, see illumos issue 6653
.if ${PORT_OPTIONS:MDTRACE}
-BROKEN= DTRACE broken with gcc/clang - reported upstream
+CFLAGS+= -no-integrated-as
.endif
post-install: