aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql++1
diff options
context:
space:
mode:
Diffstat (limited to 'databases/mysql++1')
-rw-r--r--databases/mysql++1/Makefile41
-rw-r--r--databases/mysql++1/distinfo1
-rw-r--r--databases/mysql++1/files/README25
-rw-r--r--databases/mysql++1/files/patch-aa11
-rw-r--r--databases/mysql++1/pkg-comment1
-rw-r--r--databases/mysql++1/pkg-descr5
-rw-r--r--databases/mysql++1/pkg-plist112
7 files changed, 0 insertions, 196 deletions
diff --git a/databases/mysql++1/Makefile b/databases/mysql++1/Makefile
deleted file mode 100644
index 7f81d517c606..000000000000
--- a/databases/mysql++1/Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
-# ports collection makefile for: MySQL++
-# Date created: 20th July 2000
-# Whom: Miklos Niedermayer <mico@bsd.hu>
-#
-# $FreeBSD$
-#
-
-PORTNAME= mysql++
-PORTVERSION= 1.7
-CATEGORIES= databases devel
-MASTER_SITES= http://gd.tuwien.ac.at/db/mysql/mysql++/ \
- http://www.mysql.com/Downloads/mysql++/
-
-MAINTAINER= mico@bsd.hu
-
-LIB_DEPENDS= mysqlclient:${PORTSDIR}/databases/mysql322-client
-
-HAS_CONFIGURE= yes
-CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS} -D_FIX_FOR_BSD_ "
-INSTALL_SHLIB= yes
-
-pre-configure:
- ${RM} ${WRKSRC}/examples/Makefile.in
- ${ECHO} "all:" >${WRKSRC}/examples/Makefile.in
- ${ECHO} "install:" >>${WRKSRC}/examples/Makefile.in
-
-do-install:
- @${INSTALL_PROGRAM} ${WRKDIR}/${DISTNAME}/sqlplusint/.libs/libsqlplus.so.1 ${PREFIX}/lib
- @${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/sqlplusint/.libs/libsqlplus.a ${PREFIX}/lib
- @(cd ${PREFIX}/lib && ${RM} -f libsqlplus.so && ${LN} -s libsqlplus.so.1 libsqlplus.so)
- @ranlib ${PREFIX}/lib/libsqlplus.a
- @ldconfig -m ${PREFIX}/lib
- @mkdir -p ${PREFIX}/share/examples/mysql++
- @mkdir -p ${PREFIX}/share/doc/mysql++
- @${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/examples/*.cc ${PREFIX}/share/examples/mysql++
- @${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/doc/man-text/* ${PREFIX}/share/doc/mysql++
- @mkdir -p ${PREFIX}/include/mysql
- @${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/sqlplusint/mysql++ ${WRKDIR}/${DISTNAME}/sqlplusint/*.hh ${PREFIX}/include/mysql
- @${INSTALL_DATA} ${FILESDIR}/README ${PREFIX}/share/examples/mysql++
-
-.include <bsd.port.mk>
diff --git a/databases/mysql++1/distinfo b/databases/mysql++1/distinfo
deleted file mode 100644
index db43e7dd15d8..000000000000
--- a/databases/mysql++1/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (mysql++-1.7.tar.gz) = 0a600601321c304498cfbc3c386f90ab
diff --git a/databases/mysql++1/files/README b/databases/mysql++1/files/README
deleted file mode 100644
index e73f4e71c1fd..000000000000
--- a/databases/mysql++1/files/README
+++ /dev/null
@@ -1,25 +0,0 @@
-
-
-If you haven't met mysql++ before, please take a look at the documentation
-in ../../doc/mysql++ before trying to play with these examples. Thank you.
-
-
-To compile a mysql++ program,
-
- o you have to have libmysqlclient installed on your system
- (it's in FreeBSD port mysql-client)
-
- o you have to link your programs with the sqlplus library
-
- o you have to add "-D_FIX_FOR_BSD_" to your CXXFLAGS environment
-
-
-For example, you can try to compile simple1.cc with something like this
-
-c++ -D_FIX_FOR_BSD_ -I/usr/local/include/mysql -L/usr/local/lib -lsqlplus simple1.cc -o simple1
-
-
-Happy mysql++'ing.
-
- -Miklos Niedermayer (mico@bsd.hu)
-
diff --git a/databases/mysql++1/files/patch-aa b/databases/mysql++1/files/patch-aa
deleted file mode 100644
index c556e9bfc941..000000000000
--- a/databases/mysql++1/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- sqlplusint/Makefile.in.orig Tue May 16 16:21:47 2000
-+++ sqlplusint/Makefile.in Thu Jul 20 11:22:08 2000
-@@ -91,7 +91,7 @@
- libsqlplus_la_SOURCES = coldata.cc connection.cc datetime.cc field_names.cc field_types.cc manip.cc query.cc result.cc row.cc set.cc sql_query.cc type_info.cc vallist.cc string_util.cc
-
-
--libsqlplus_la_LDFLAGS = -version-info $(SQLPLUS_MAJOR_VERSION):$(SQLPLUS_MINOR_VERSION):$(SQLPLUS_MICRO_VERSION)
-+libsqlplus_la_LDFLAGS = -version-info $(SQLPLUS_MAJOR_VERSION)
-
- include_HEADERS = sqlplus.hh coldata1.hh coldata2.hh coldata3.hh coldata4.hh compare1.hh compare2.hh compare3.hh connection0.hh connection1.hh connection2.hh connection3.hh const_string1.hh const_string2.hh const_string3.hh convert1.hh convert2.hh convert3.hh custom-macros.hh custom.hh datetime1.hh datetime2.hh datetime3.hh field_names1.hh field_names2.hh field_names3.hh field_types1.hh field_types2.hh field_types3.hh fields1.hh fields2.hh manip1.hh manip2.hh manip3.hh null1.hh null2.hh null3.hh query1.hh query2.hh query3.hh resiter1.hh result1.hh result2.hh result3.hh row1.hh row2.hh row3.hh set1.hh set2.hh set3.hh sql_query0.hh sql_query1.hh sql_query2.hh sql_query3.hh sql_string1.hh sql_string2.hh sql_string3.hh stream2string1.hh stream2string2.hh stream2string3.hh tiny_int1.hh tiny_int2.hh tiny_int3.hh type_info1.hh type_info2.hh type_info3.hh vallist1.hh vallist2.hh vallist3.hh string_util.hh define_short defs
-
diff --git a/databases/mysql++1/pkg-comment b/databases/mysql++1/pkg-comment
deleted file mode 100644
index 3e0c1b98e81b..000000000000
--- a/databases/mysql++1/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-Complex C++ API for MySQL (needs mysql-client)
diff --git a/databases/mysql++1/pkg-descr b/databases/mysql++1/pkg-descr
deleted file mode 100644
index 31e6d161eea8..000000000000
--- a/databases/mysql++1/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
- Mysql++ is a complex C++ API for Mysql (And other SQL Databases Soon).
- The goal of this API is too make working with Queries as easy as
- working with other STL Containers.
-
- WWW: http://www.mysql.com/download_mysql++.html
diff --git a/databases/mysql++1/pkg-plist b/databases/mysql++1/pkg-plist
deleted file mode 100644
index 4789fc522dd2..000000000000
--- a/databases/mysql++1/pkg-plist
+++ /dev/null
@@ -1,112 +0,0 @@
-include/mysql/mysql++
-include/mysql/bad_query.hh
-include/mysql/coldata1.hh
-include/mysql/coldata2.hh
-include/mysql/coldata3.hh
-include/mysql/coldata4.hh
-include/mysql/compare1.hh
-include/mysql/compare2.hh
-include/mysql/compare3.hh
-include/mysql/connection0.hh
-include/mysql/connection1.hh
-include/mysql/connection2.hh
-include/mysql/connection3.hh
-include/mysql/const_string1.hh
-include/mysql/const_string2.hh
-include/mysql/const_string3.hh
-include/mysql/convert1.hh
-include/mysql/convert2.hh
-include/mysql/convert3.hh
-include/mysql/custom-macros.hh
-include/mysql/custom.hh
-include/mysql/fields1.hh
-include/mysql/datetime1.hh
-include/mysql/datetime2.hh
-include/mysql/datetime3.hh
-include/mysql/field_names1.hh
-include/mysql/field_names2.hh
-include/mysql/field_names3.hh
-include/mysql/field_types1.hh
-include/mysql/field_types2.hh
-include/mysql/field_types3.hh
-include/mysql/fields2.hh
-include/mysql/manip1.hh
-include/mysql/manip2.hh
-include/mysql/manip3.hh
-include/mysql/null1.hh
-include/mysql/null2.hh
-include/mysql/null3.hh
-include/mysql/query1.hh
-include/mysql/query2.hh
-include/mysql/query3.hh
-include/mysql/resiter1.hh
-include/mysql/result1.hh
-include/mysql/result2.hh
-include/mysql/result3.hh
-include/mysql/row1.hh
-include/mysql/row2.hh
-include/mysql/row3.hh
-include/mysql/set1.hh
-include/mysql/set2.hh
-include/mysql/set3.hh
-include/mysql/sql_query0.hh
-include/mysql/sql_query1.hh
-include/mysql/sql_query2.hh
-include/mysql/sql_query3.hh
-include/mysql/sql_string1.hh
-include/mysql/sql_string2.hh
-include/mysql/sql_string3.hh
-include/mysql/sqlplus.hh
-include/mysql/stream2string1.hh
-include/mysql/stream2string2.hh
-include/mysql/stream2string3.hh
-include/mysql/string_util.hh
-include/mysql/tiny_int1.hh
-include/mysql/tiny_int2.hh
-include/mysql/tiny_int3.hh
-include/mysql/type_info1.hh
-include/mysql/type_info2.hh
-include/mysql/type_info3.hh
-include/mysql/vallist1.hh
-include/mysql/vallist2.hh
-include/mysql/vallist3.hh
-lib/libsqlplus.so.1
-lib/libsqlplus.a
-lib/libsqlplus.so
-share/doc/mysql++/1_Introduction.txt
-share/doc/mysql++/2_Overview.txt
-share/doc/mysql++/3_Important.txt
-share/doc/mysql++/4_Tutorial.txt
-share/doc/mysql++/5_Class.txt
-share/doc/mysql++/6_Template.txt
-share/doc/mysql++/7_Specialized.txt
-share/doc/mysql++/8_Long.txt
-share/doc/mysql++/A_Changelog.txt
-share/doc/mysql++/About_this.txt
-share/doc/mysql++/Appendices.txt
-share/doc/mysql++/B_Do.txt
-share/doc/mysql++/C_Credits.txt
-share/doc/mysql++/Contents.txt
-share/doc/mysql++/D_Copyright.txt
-share/doc/mysql++/E_Feedback.txt
-share/doc/mysql++/Introductory_Material.txt
-share/doc/mysql++/Usage.txt
-share/doc/mysql++/index.txt
-share/doc/mysql++/manual.txt
-share/examples/mysql++/cgi_image.cc
-share/examples/mysql++/complic1.cc
-share/examples/mysql++/custom1.cc
-share/examples/mysql++/custom2.cc
-share/examples/mysql++/custom3.cc
-share/examples/mysql++/custom4.cc
-share/examples/mysql++/fieldinf1.cc
-share/examples/mysql++/load_file.cc
-share/examples/mysql++/resetdb.cc
-share/examples/mysql++/simple1.cc
-share/examples/mysql++/sinisa_ex.cc
-share/examples/mysql++/updel_x_.cc
-share/examples/mysql++/util.cc
-share/examples/mysql++/README
-@unexec rmdir include/mysql 2>/dev/null || true
-@dirrm share/doc/mysql++
-@dirrm share/examples/mysql++